Citrix® StoreFront™ stores monitoring
Create a StoreFront monitor by using the CLI
add lb monitor <monitorName> STOREFRONT <string> -storeName <string> [-storefrontacctservice ( YES | NO )] -secure ( YES | NO )
show lb monitor <monitorName>
Example
add lb monitor storefront_ssl STOREFRONT -storename myStore -storefrontacctservice YES -secure YES
Create a StoreFront monitor by using the GUI
-
Interval: The time interval between two successive probes. The default time interval is 5 seconds.
-
Response Time-out: The duration for which NetScaler waits before it marks a probe as FAILED. The default duration is 2 seconds.
-
Store Name: The StoreFront store that must be monitored. By default, the user monitor uses the /Citrix/StoreWeb store for monitoring.
-
StoreFront Account Service: Enable or disable probing for the StoreFront account service.
-
Check Backend Services: This option enables the monitoring of services running on the StoreFront server.
-
Secure: Enable this option if you are using HTTPS.
Extended StoreFront monitor
Configure the extended StoreFront monitor by using the GUI
-
Navigate to Traffic Management > Load Balancing > Monitors and click Add.
-
Select the type as USER.
-
In the Basic Parameters section, provide the following details:
-
Secure Arguments: Provide the username, password, and the store name in this field. The details must be in the format
user=<DomainName\username>;password=<password>;store=/Citrix/StoreWeb. If the store name is not provided, the default store/Citrix/StoreWebis used for monitoring. -
Script name: Select the nssf_extend.pl script.
-
Interval and Response Time-Out: Set the time interval and response to greater values, preferably in minutes. This ensures the completion of the monitor probe as the StoreFront monitor makes multiple HTTP/HTTPS calls.
-
Configure the extended StoreFront monitor by using the CLI
add lb monitor <monitorName> USER -scriptName nssf_extend.pl -secureArgs “user=<DomainName\username>;password=<password>;store=/Citrix/StoreWeb;” -interval 2 Min -resptimeout 1 Min
Error messages
| Error | Description |
|---|---|
| Insufficient number of arguments | The admin must provide the user name and password in the Secure Arguments parameter. |
| Invalid argument format | The admin must provide the secure arguments in the correct format - “user=<DomainName><username>;password=<password>;store=/Citrix/Storeweb or user=<DomainName><username>;password=<password> |
| ASP.NET_SessionId or CsrfToken are not generated | The CSRF token or ASP.NET_SessionId cookies were not found in the response from StoreFront. |
| Unable to get client configuration | The monitor is unable to fetch the client configuration settings from StoreFront. |
| CtxsDeviceId cookie is missing | The CtxsDeviceId cookie was not found in the response from StoreFront. |
| Unable to fetch API endpoint for authentication methods | The StoreFront monitor is unable to fetch the API endpoint to get the list of the configured authentication methods. |
| Login with username/password is not supported | The username and password method is disabled on StoreFront. It must be enabled on StoreFront. |
| Unable to fetch Authentication endpoint | The endpoint for authentication is not reachable from the monitor. |
| Incorrect username or password | The test user credentials configured for the StoreFront monitor are invalid. |
| Incorrect Domain name Configured | The domain name configured for the StoreFront monitor is incorrect. |
| Authentication unsuccessful | Authentication has failed on StoreFront. |
| Authorization cookie is not generated | The authorization cookie was not found in response from StoreFront. |
| Enumeration doesn't have all the required fields | No apps were enumerated or the app enumeration was incomplete. |
| App Enumeration Failure | The enumeration of apps from StoreFront has failed. |
| Logout Unsuccessful | The logoff of the session is unsuccessful. It might result in a build-up of unexpired sessions on StoreFront. |
show service <name> and show servicegroup <name> commands, you can view the status of the monitor probing on the Last response field.
show service svc
State: UP
Last state change was at Wed Aug 2 08:53:37 2023
Time since last state change: 0 days, 00:00:21.900
...
Monitor Name: extended_monitor
State: DOWN Weight: 1 Passive: 0
Probes: 3 Failed [Total: 3 Current: 3]
Last response: Failure - Authorization cookie is not generated
Response Time: 5000.000 millisec
show servicegroup sg_ext_monitor
sg_ext_monitor - HTTP
State: ENABLED Effective State: PARTIAL-UP Monitor Threshold : 0
Max Conn: 0 Max Req: 0 Max Bandwidth: 0 kbits
...
1) Monitor Name: extended_monitor State: ENABLED Weight: 1 Passive: 0
1) 10.106.44.33:80 State: UP Server Name: 10.106.44.33 Server ID: None Weight: 1 Order: Default
...
Monitor Name: extended_monitor State: UP Passive: 0
Probes: 4 Failed [Total: 0 Current: 0]
Last response: Success - Probe succeeded.
Response Time: 1.039 millisec
2) 10.106.44.34:80 State: DOWN Server Name: 10.106.44.34 Server ID: None Weight: 1 Order: Default
...
Monitor Name: extended_monitor State: DOWN Passive: 0
Probes: 4 Failed [Total: 4 Current: 4]
Last response: Failure - Authorization cookie is not generated