How domain name system supports GSLB
Delegation
sales.citrix.com, education.citrix.com, and support.citrix.com. The corresponding departments can maintain their own set of Name servers that are authoritative for their subdomain, and then maintain their own set of host name to address mappings. No single department is responsible for maintaining all of Citrix address records. Each department can change addresses and modify topologies, and not impose more work at the higher-level domain or organization.
Benefits of the hierarchical topology
-
Scalability
-
Adding caching functionality into Name servers at each level, where a DNS request is served by a host that is not authoritative for a particular domain but can contribute the answer to the query, and cut down on congestion and response time.
-
Caching also creates redundancy and resiliency to server failure. If one name server fails, it is still possible that records can be served from other servers that have recent cached copies of the same records.
Resolvers
-
Querying a name server.
-
Interpreting responses (which might be resource records or an error).
-
Returning the information to the programs that requested it.
Name Servers
citrix.com, while sales.citrix.com is a separate zone if that zone is delegated to another Name Server within the subdomain. In this case, the primary Citrix zone can include citrix.com, it.citrix.com, and support.citrix.com. Because the sales.citrix.com is delegated, it is not part of the zone that the citrix.com Name Server is authoritative over. The following diagram shows the two zones.
ns1.citrix.com does not contain information about the sales.citrix.com subdomain. Instead, it contains pointers to the Name servers that are authoritative for the ns1.sales.citrix.com subdomain.
Root name servers and query resolution
Recursive and non-recursive queries
-
Recursive query: The query between the resolver and the locally configured Name server is recursive. This means that the Name server receives the query and does not respond to the resolver until the query is fully answered, or an error is returned. If the Name Server receives a referral to the query, then the Name server follows the referral until the Name server finally receives the answer (IP address) returned.
-
Non-recursive query: The query that the locally configured Name server makes to the subsequent authoritative domain-level Name server is non-recursive (or iterative). Each request is immediately responded with either a referral to a lower-level authoritative server or the answer to the query, if the queried Name server contains the answer in its data files or its cache.
Caching
Resource record types
| Resource record type | Description | RFC |
|---|---|---|
| A | A host address | RFC 1035 |
| NS | An authoritative name server | RFC 1035 |
| MD | A mail destination (Obsolete - use MX) | RFC 1035 |
| MF | A mail forwarder (Obsolete - use MX) | RFC 1035 |
| CNAME | The canonical name for an alias | RFC 1035 |
| SOA | Marks the start of a zone of authority | RFC 1035 |
| WKS | A well known service description | RFC 1035 |
| PTR | A domain name pointer | RFC 1035 |
| HINFO | Host information | RFC 1035 |
| MINFO | Mailbox or mail list information | RFC 1035 |
| MX | Mail exchange | RFC 1035 |
| TXT | Text strings | RFC 1035 |
| AAAA | IP6 Address | RFC 3596 |
| SRV | Server selection | RFC 2782] |
How GSLB supports DNS
www.citrix.com, then the following Bind SOA file can be used to delegate requests to www.citrix.com to Name Servers: Netscaler1 and Netscaler2.
###########################################################################
@ IN SOA citrix.com. hostmaster.citrix.com. (
1 ; serial
3h ; refresh
1h ; retry
1w ; expire
1h ) ; negative caching TTL
IN NS ns1
IN NS ns2
IN MX 10 mail
ns1 IN A 10.10.10.10
ns2 IN A 10.10.10.20
mail IN A 10.20.20.50
### Old Configuration if www was not delegated to a GSLB name server
www IN A 10.20.20.50
### Updated Configuration
Netscaler1 IN A xxx.xxx.xxx.xxx
Netscaler2 IN A yyy.yyy.yyy.yyy
www IN NS Netscaler1.citrix.com.
www IN NS Netscaler2.citrix.com.
###
IN MX 20 mail2
mail2 IN A 10.50.50.20
###########################################################################
-
Site with the least number of current connections
-
Site that is closest to the LDNS server, which sent the request based on round trip times (RTT).
Metric exchange protocol
-
Site metric exchange: This is a polling exchange model. For example, if site1 has a configuration for site2 services, then every second site1 asks site2 for the status of the GSLB services. Site2 responds with the state and other load details.
-
Network metric exchange: This is the LDNS RTT information exchange, which is used in the dynamic proximity load balancing algorithm. This is a push exchange model. Every five seconds, each site pushes its data to other participating sites.
-
Persistency exchange: This is for SOURCEIP persistency exchange. This is also a push exchange model. Every five seconds, each site pushes its data to other participating sites.