たとえば、プライマリCitrix Application Delivery Controller (NetScaler) インスタンスを交換またはアップグレードする必要がある場合、フェイルオーバーを強制したいことがあります。プライマリインスタンスまたはセカンダリインスタンスのいずれかからフェイルオーバーを強制できます。プライマリインスタンスでフェイルオーバーを強制すると、プライマリがセカンダリになり、セカンダリがプライマリになります。強制フェイルオーバーは、プライマリインスタンスがセカンダリインスタンスがUPであることを判断できる場合にのみ可能です。
強制フェイルオーバーは伝播または同期されません。強制フェイルオーバー後の同期ステータスを表示するには、インスタンスのステータスを表示できます。
強制フェイルオーバーは、次のいずれかの状況で失敗します。
-
スタンドアロンシステムでフェイルオーバーを強制した場合。
-
セカンダリインスタンスが無効または非アクティブである。セカンダリインスタンスが非アクティブ状態の場合、フェイルオーバーを強制するには、その状態がUPになるまで待つ必要があります。
-
セカンダリインスタンスがセカンダリのままであるように構成されている。
NetScalerインスタンスは、強制フェイルオーバーコマンドを実行したときに潜在的な問題を検出した場合、警告メッセージを表示します。メッセージには、警告をトリガーした情報が含まれており、続行する前に確認を求めます。
プライマリインスタンスまたはセカンダリインスタンスでフェイルオーバーを強制できます。
NetScaler Consoleを使用してセカンダリNetScalerインスタンスへのフェイルオーバーを強制するには:
-
NetScaler Consoleで、Infrastructure > Instancesに移動します。VPXタブに移動し、インスタンスを選択します。
-
選択したインスタンスタイプの下にリストされているインスタンスから、HAセットアップのインスタンスを選択します。
-
Actionボックスから、Force Failoverを選択します。
-
強制フェイルオーバーアクションを確認するために、Yesをクリックします。