テレメトリの収集とアップロードに関する問題のトラブルシューティングのための診断機能

最終公開日 : Sep 25, 2026
リリース14.1ビルド56.xより前は、診断機能はこれらのエンドポイントURLへのアウトバウンド接続を検査し、到達可能な状態にあるかどうかを通知するのに役立ちます。NetScaler On-prem リリース14.1ビルド56.x以降では、コレクターレベル(コンソール)とデバイスレベル(個々のNetScalerインスタンス)の両方で、テレメトリの収集とアップロードに関する問題を特定し、トラブルシューティングを行うための強化された診断機能が提供されます。

リリース14.1ビルド56.x以降の診断の動作

注:
リリース14.1ビルド56.x以降、テレメトリ診断機能が強化され、コレクターレベル(コンソール)とデバイスレベル(個々のNetScalerインスタンス)の両方で、テレメトリの収集とアップロードに関する問題を特定し、トラブルシューティングを行うことができます。
すべての管理対象NetScalerインスタンスは、コンプライアンスを維持するためにテレメトリデータを送信する必要があります。しかし、接続または構成の問題により、テレメトリのアップロードと収集が失敗することがあります。 Console on-prem のNetScalerテレメトリページにある診断機能は、両方のレベルで問題を迅速に特定し、トラブルシューティングを行うのに役立ちます。
  • コレクターレベル(コンソール):データが正常にアップロードされたかどうかを確認するため。
  • デバイスレベル(個々のNetScalerインスタンス):NetScalerインスタンスからデータが収集されたかどうかを確認するため。
NetScaler テレメトリ診断

仕組み

診断プロセスに関わる大まかな手順は次のとおりです。
  • 自動実行:診断は24時間ごとに自動的に実行されます。
  • オンデマンド実行:ユーザーは必要に応じて、特に問題の修正を試みた後に、診断を手動で実行できます。
  • ステータスインジケーター:結果は明確なステータスで表示されます。
    • 成功:問題は検出されませんでした。
    • 要対応: 1つ以上の問題にユーザーの対応が必要です。
注:
詳細なエラーログと軽減策については、詳細を表示をクリックするか、エラーが強調表示されている領域をクリックしてください。
詳細を表示

コレクターレベル(コンソール)診断

このセクションでは、NetScaler Consoleが管理対象デバイスからデータを正常に収集し、必要な宛先にアップロードしているかどうかを確認します。
チェックフィールド 説明
実行時間 管理対象のNetScalerインスタンスからの最後のテレメトリ収集のタイムスタンプ。
パッケージバージョン このチェックは、Console on-premにインストールされているテレメトリパッケージのバージョンを特定し、最新のデータセットが収集されていることを確認します。
Evergreenダウンロードステータス (自動モードのみ)Console on-premは、ダウンロードサービスURLから更新されたテレメトリスクリプトパッケージを24時間ごとにチェックします。情報(i)アイコンにカーソルを合わせると、障害の具体的な原因が表示されます。軽減策の詳細については、障害ステータスをクリックしてください。
接続ステータス (自動モードのみ) 必要なURLがホワイトリストに登録され、到達可能であることを確認します。例えば、プロキシの誤設定による接続の問題は、コンソールがこれらのURLに到達するのを妨げます。情報(i)アイコンにカーソルを合わせると、到達不能の具体的な原因が表示されます。軽減策の詳細については、到達不能ステータスをクリックしてください。
- ダウンロードサービスURL: 最新のテレメトリパッケージダウンロードのソース。
- 自動有効化チャネルURL: テレメトリデータをアップロードするための宛先。
テレメトリ実行の詳細

デバイスレベル (NetScaler) 診断

コンソールは、管理対象の各NetScalerインスタンスにテレメトリ収集スクリプトをプッシュし、データを収集し、アップロードのために準備することで、デバイスレベルの診断を実行します。
デバイステレメトリ詳細テーブルには、このプロセスの結果が以下のように表示されます。
  • デバイスの詳細
  • テレメトリステータス
  • エラーコードとエラーメッセージ
詳細なエラー情報と軽減策については、赤く強調表示されたエラーの詳細をクリックしてください。
デバイステレメトリの詳細
軽減策: 各エラーコードは、軽減策テーブルの推奨ソリューションにマッピングされています。問題の修正には、推奨事項に従ってください。
軽減策の表(/en-us/netscaler-application-delivery-management-software/media/mitigation-table.png)

エラーテーブルマッピング

エラーコード エラーメッセージ お客様の対応
1161 サーバーホスト名の解決に失敗しました サーバーアドレスを解決できません。ネットワークおよびNetScalerコンソールサーバー/エージェントのDNSサーバー構成を確認してください。
1162 サーバーアドレスを解決できません。ネットワークおよびNetScalerコンソールサーバー/エージェントのDNSサーバー構成を確認してください。 サーバーに接続できません。ファイアウォール、プロキシ設定、およびネットワーク接続を確認してください。また、URL download.citrixnetworkapi.net がネットワークまたはプロキシ経由でアクセス可能であることを確認してください。
1165 プロキシエラー プロキシ構成を確認し、プロキシ経由でネットワーク接続が機能していることを確認してください。
1166 プロキシ認証に失敗しました NetScalerコンソールでプロキシ資格情報を確認してください。
1170 SSL証明書の検証に失敗しました。 ネットワークでSSLインターセプターを使用している場合は、NetScalerコンソールに適切なルート証明書がインストールされていることを確認してください。
1171 SSL証明書の有効期限が切れました SSL証明書の有効期限が切れました。
1172 SSL証明書の検証に失敗しました。 ネットワークでSSLインターセプターを使用している場合は、NetScalerコンソールに適切なルート証明書がインストールされていることを確認してください。
1173 SSL証明書の検証に失敗しました。 これは自己署名証明書が原因である可能性があります。ネットワークでSSLインターセプターを使用している場合は、NetScalerコンソールに適切なルート証明書がインストールされていることを確認してください。
1261 サーバーのホスト名の解決に失敗しました サーバーアドレスを解決できません。ネットワークおよびNetScalerコンソールサーバー/エージェントのDNSサーバー構成を確認してください。
1262 リクエスト接続タイムアウト サーバーに接続できません。ファイアウォール、プロキシ設定、およびネットワーク接続を確認してください。両方のURL (download.citrixnetworkapi.net, safehaven.adm.cloud.com) がネットワークから、またはプロキシ経由でアクセス可能であることを確認してください。
1265 プロキシエラー プロキシ構成を確認し、プロキシ経由でネットワーク接続が機能していることを確認してください。
1266 プロキシ認証に失敗しました。 NetScalerコンソールでプロキシ資格情報を確認してください。
1270 SSL証明書の検証に失敗しました ネットワークでSSLインターセプターを使用している場合は、適切なルート証明書がNetScalerコンソールにインストールされていることを確認してください。
1271 SSL証明書の有効期限が切れました。 サーバーのSSL証明書の有効期限が切れました。
1272 SSL証明書の検証に失敗しました ネットワークでSSLインターセプターを使用している場合は、適切なルート証明書がインストールされていることをNetScalerコンソールで確認してください。
1273 SSL証明書の検証に失敗しました これは自己署名証明書が原因である可能性があります。ネットワークでSSLインターセプターを使用している場合は、適切なルート証明書がインストールされていることをNetScalerコンソールで確認してください。
1361 サーバーのホスト名の解決に失敗しました サーバーアドレスを解決できません。ネットワークおよびNetScalerコンソールサーバー/エージェントのDNSサーバー構成を確認してください。
1362 リクエスト接続のタイムアウト。 サーバーに接続できません。ファイアウォール、プロキシ設定、およびネットワーク接続を確認してください。URL safehaven.adm.cloud.com がネットワークまたはプロキシ経由でアクセス可能であることを確認してください。
1365 プロキシエラー プロキシ設定を確認し、プロキシ経由でネットワーク接続が機能していることを確認してください。
1366 プロキシ認証に失敗しました NetScalerコンソールでプロキシ資格情報を確認してください。
1370 SSL証明書の検証に失敗しました。 ネットワークでSSLインターセプターを使用している場合は、NetScalerコンソールに適切なルート証明書がインストールされていることを確認してください。
1371 SSL証明書の有効期限が切れました サーバーのSSL証明書の有効期限が切れました。
1372 SSL証明書の検証に失敗しました。 ネットワークでSSLインターセプターを使用している場合は、NetScalerコンソールに適切なルート証明書がインストールされていることを確認してください。
1373 SSL証明書の検証に失敗しました。 これは、自己署名証明書が原因である可能性があります。ネットワークでSSLインターセプターを使用している場合は、適切なルート証明書がNetScalerコンソールにインストールされていることを確認してください。
2000 このデバイスではテレメトリがスキップされました。 これは、このデバイスが別のNetScaler Console/Service/Agentによって管理されているためである可能性があります。他のコレクターがテレメトリデータを正常に送信していることを確認してください。
2100 インスタンスの状態がダウンしているか、到達できません。 インスタンスが実行中で到達可能であることを確認してください。
2250 SSH認証エラー NetScalerコンソールで、デバイスのデバイスプロファイルが適切に構成されていることを確認してください。
2251 SSH接続のタイムアウト/拒否。 接続がファイアウォールまたはネットワークポリシーによって一時的にブロックされているか、デバイスに到達できない可能性があります。ネットワーク接続を確認し、SSHポートにアクセスできることを確認してください。
2252 ホストキーの検証に失敗しました 管理者とサーバーのIDを確認し、古いキーを削除してください: ssh-keygen -R <server_address>。
2350 SSH認証エラー。 デバイスのデバイスプロファイルがNetScalerコンソールで適切に設定されていることを確認してください。
2351 SSHがデバイスへの接続に失敗しました 接続はファイアウォールまたはネットワークポリシーによって一時的にブロックされているか、デバイスに到達できない可能性があります。ネットワーク接続を確認し、SSHポートがアクセス可能であることを確認してください。

リリース14.1ビルド56.x以前の診断動作

リリース14.1ビルド51.x以前では、診断機能はこれらのエンドポイントURLへのアウトバウンド接続を検査し、到達可能状態であるかどうかを通知します。
アウトバウンド接続
エンドポイントURLが到達可能状態であることを確認したら、NetScaler® Telemetryページに移動をクリックします。
エンドポイントの到達可能性
いずれかの前提条件が満たされない場合、診断チェックは到達できないエンドポイントを表示し、URLが到達可能であることを確認する必要があります。詳細を表示するには、前提条件を表示をクリックします。
前提条件
エンドポイントURLに到達可能かどうかを確認するには、診断の実行をクリックして診断を実行できます。
診断の実行(/en-us/netscaler-application-delivery-management-software/media/ns-telemetry-diagnosis.png)
何も対策を講じない場合、オンプレミスのNetScaler ConsoleはNetScalerテレメトリプログラムに準拠しない可能性があります。
自動有効化チャネルの一部として、NetScaler Consoleオンプレミスで最新のCVEアップデートを含むセキュリティアドバイザリ機能を使用できます。セキュリティアドバイザリ機能を使用すると、NetScalerインスタンスを危険にさらしているCVEを特定し、修正を推奨できます。NetScalerインスタンスに影響を与えている最新のCVEの詳細は、セキュリティアドバイザリで確認できます。詳細については、「セキュリティアドバイザリ」を参照してください。
注:
セキュリティアドバイザリを無効にすることもできます。セキュリティアドバイザリを無効にするか、自動テレメトリモードをオプトアウトするか、または前提条件のいずれかが失敗した場合、新しいCVEアップデートは利用できず、既存または最後に更新されたCVEでのみセキュリティアドバイザリを使用できます。
テレメトリのホームページ(/en-us/netscaler-application-delivery-management-software/media/ns-telemetry-homepage.png)
自動テレメトリ収集が正常に有効になると、最初のアップロードは24時間以内に行われます。その後のアップロードは24時間ごとに自動的に行われます。アップロードが完了すると、ステータスは成功に変わります。
アップロードステータス(/en-us/netscaler-application-delivery-management-software/media/ns-telemetry-upload-status.png)
アップロードが失敗した場合は、エンドポイントURLに到達可能であることを確認してください。ステータスが到達可能と表示されていてもアップロードが失敗する場合は、カスタマーケアにお問い合わせください。

テレメトリアップロードの通知

デフォルトでは、テレメトリアップロードのメール通知が有効になっています。メール通知を受信するための前提条件は、メール配信リストを構成することです。詳細については、「通知設定の構成」を参照してください。管理者として、次のシナリオでメール通知を受信します。
  • テレメトリ収集の失敗 - 問題が解決されるまで、24時間ごとにメール通知が送信されます。通知には、問題の影響を受けるNetScalerおよびConsoleのIPアドレスが含まれます。
  • 自動モードによるアップロードの失敗 - 問題が解決されるまで、24時間ごとにメール通知が届きます。
  • 手動アップロードの期限が近づいている(手動モードが有効な場合のみ) - イベント中に1通のメール通知が届き、アップロード完了後に別のメールが届きます。
  • 手動アップロードの期限超過 (手動モードが有効な場合のみ) - イベント中に1通のメール通知が届き、アップロード完了後に別のメールが届きます。
注:
NetScalerデバイスでのテレメトリ収集の問題に関する通知は、ユーザーがコンソールユーザーインターフェイスにログインするたびにバナーとしても表示されます。
以下は、NetScalerデバイスでのテレメトリ収集失敗に関するメールとバナー通知の例です。
メール通知製品内バナー
メール通知を無効にできます。無効にするには:
  1. 設定 > 管理 > イベント通知とダイジェストの構成に移動します。
  2. イベント通知 > システム通知の構成で、TelemetryMonitoringを検索し、この通知を削除して、保存をクリックします。
    通知