ゲートウェイインサイト
注意点
-
Gateway Insightは、以下の展開でサポートされています。
-
アクセスゲートウェイ
-
統合ゲートウェイ
-
-
NetScaler Consoleのリリースとビルドは、NetScaler Gatewayアプライアンスのリリースとビルドと同じかそれ以降である必要があります。
-
Advancedライセンスを持つNetScalerインスタンスでは、1時間分のGateway Insightレポートを表示できます。1時間を超えるGateway Insightレポートを表示するには、Premiumライセンスが必須です。
制限事項
-
認証方法が証明書ベースの認証として構成されている場合、NetScaler GatewayはGateway Insightをサポートしません。
-
Gateway Insightレポートの場合、NetScalerアプライアンスから地理位置情報が提供されません。
-
仮想ICAアプリケーションおよびデスクトップのユーザーログオンの成功、遅延、およびアプリケーションレベルの詳細は、HDX™ Insight Usersダッシュボードでのみ表示されます。
-
ダブルホップモードでは、2番目のDMZにあるNetScaler Gatewayアプライアンスでの障害の可視性は利用できません。
-
リモートデスクトッププロトコル (RDP) デスクトップアクセスに関する問題は報告されません。
-
Gateway Insightは、以下の認証タイプをサポートしています。これら以外の認証タイプが使用されている場合、Gateway Insightでいくつかの不一致が見られる可能性があります。
-
ローカル
-
LDAP
-
RADIUS
-
TACACS
-
SAML
-
ネイティブOTP
-
OAuth-OpenID コネクトOAuth-OpenID Connect認証の場合、NetScalerはOAuth-OpenID Connectの依拠当事者 (RP) またはOAuth-OpenID ConnectのIDプロバイダー (IdP) として機能できます。認証が成功すると、ユーザー名はGateway Insightレポートの「ユーザー」タブに報告されます。ただし、セッションがIdPまたはRPのどちらで作成されたかを特定することはできません。注: OAuth-OpenID Connect認証は、NetScaler Consoleリリース13.1ビルド4.xx以降でサポートされています。
-
Gateway Insightを有効にする
-
Infrastructure > Instancesに移動し、AppFlowを有効にするインスタンスを選択します。
-
Select Actionリストから、Configure Analyticsを選択します。
-
Configure Insightページで、Configure Analyticsの下にあるNetScaler Gatewayを選択します。
-
仮想サーバーを選択し、Enable AppFlowをクリックします。
-
Enable AppFlow画面で、Select Expressionリストのtrueをクリックします。
-
Transport Modeの横にあるLogstreamチェックボックスをオンにします。注転送モードとしてIPFIXまたはLogstreamのいずれかを選択できます。IPFIXおよびLogstreamの詳細については、Logstreamの概要を参照してください。
-
OKをクリックします。
NetScaler Consoleバージョン13.0 Build 41.x以降の場合
-
Infrastructure > Instancesに移動し、インスタンスを選択します。
-
「Select Action」リストから、「Configure Analytics」を選択します。
-
仮想サーバーを選択し、「Enable Analytics」をクリックします。
-
「Advanced Options」の下で:
-
「Logstream」を選択します。
-
「NetScaler Gateway」を選択します。
-
-
「OK」をクリックします。
GUIを使用してNetScaler GatewayアプライアンスでAppFlow認証、承認、および監査ユーザー名ログを有効にする
-
Configuration > System > AppFlow > Settings に移動し、「Change AppFlow Settings」をクリックします。
-
「Configure AppFlow Settings」画面で、「AAA Username」を選択し、「OK」をクリックします。
Gateway Insightレポートの表示
EPA、SSO、認証、承認、およびアプリケーション起動の失敗を表示するには
-
NetScaler Consoleで、Gateway > Gateway Insight に移動します。
-
ユーザーの詳細を表示したい期間を選択します。タイムスライダーを使用して、選択した期間をさらにカスタマイズできます。Goをクリックします。
-
EPA (エンドポイント分析)、認証、承認、SSO (シングルサインオン)、またはアプリケーション起動のタブをクリックして、失敗の詳細を表示します。

セッションモード、クライアント、およびユーザー数の概要を表示するには

ユーザーのGateway Insightレポートを表示する
-
NetScaler Gatewayアプライアンスに関連付けられているすべてのユーザー。
-
ユーザーのEPA、認証、SSO、およびアプリケーション起動の失敗。
-
ユーザーのアクティブセッションと終了セッションの詳細。
-
フルトンネル、クライアントレスVPN、ICA®プロキシなどのセッションモードの種類。
ユーザーの詳細を表示するには
-
NetScaler Consoleで、Gateway > Gateway Insight > Usersに移動します。
-
ユーザーの詳細を表示したい期間を選択します。タイムスライダーを使用して、選択した期間をさらにカスタマイズできます。「Go」をクリックします。
-
その期間中にすべてのユーザーが使用したアクティブユーザー数、アクティブセッション数、バイト数、ライセンス数を表示できます。Gateway Insightユーザーレポート(/en-us/netscaler-application-delivery-management-software/media/gateway-insight-reports-users.png)
-
ユーザー詳細 - NetScaler Gatewayアプライアンスに関連付けられている各ユーザーのインサイトを表示できます。「Gateway」>「Gateway Insight」>「Users」に移動し、ユーザーをクリックすると、セッションモード、オペレーティングシステム、ブラウザなど、選択したユーザーのインサイトが表示されます。ユーザー詳細(/en-us/netscaler-application-delivery-management-software/media/gw-user-details.png)
-
選択したゲートウェイのユーザーとアプリケーション - 「Gateway」>「Gateway Insight」>「Gateway」に移動し、ゲートウェイドメイン名をクリックすると、選択したゲートウェイに関連付けられている上位10個のアプリケーションと上位10人のユーザーが表示されます。ユーザーとアプリケーション(/en-us/netscaler-application-delivery-management-software/media/gw-user-app.png)
-
アプリケーションとユーザーのその他のオプションを表示 – 10を超えるアプリケーションとユーザーの場合、「Applications and Users」のその他アイコンをクリックすると、選択したゲートウェイに関連付けられているすべてのユーザーとアプリケーションの詳細を表示できます。
-
棒グラフをクリックして詳細を表示 – 棒グラフをクリックすると、関連する詳細を表示できます。たとえば、Gateway > Gateway Insight > Gateway に移動し、ゲートウェイの棒グラフをクリックすると、ゲートウェイの詳細が表示されます。棒グラフ(/en-us/netscaler-application-delivery-management-software/media/bar-graph.png)
-
ユーザーのアクティブセッションと終了セッション。Gateway Insightのアクティブセッションと終了セッション(/en-us/netscaler-application-delivery-management-software/media/gateway-insight-active-terminated-session.png)
-
「アクティブセッション」のゲートウェイドメイン名とゲートウェイIPアドレス。
-
ユーザーのログイン期間。Gateway Insightのログイン期間(/en-us/netscaler-application-delivery-management-software/media/gateway-insight-login-duration.png)
-
ユーザーのログアウトセッションの理由。ログアウトの理由は次のとおりです。
-
セッションがタイムアウトしました
-
内部エラーのためログアウトしました
-
非アクティブセッションのタイムアウトのためログアウトしました
-
ユーザーがログアウトしました
-
管理者がセッションを停止しました
-
アプリケーションのGateway Insightレポートの表示
アプリケーションの詳細を表示するには
-
NetScaler Consoleで、ゲートウェイ > Gateway Insight > アプリケーションに移動します。
-
アプリケーションの詳細を表示する期間を選択します。タイムスライダーを使用して、選択した期間をさらにカスタマイズできます。「Go」をクリックします。
ゲートウェイのGateway Insightレポートの表示
ゲートウェイの詳細を表示するには
-
NetScaler Consoleで、Gateway > Gateway Insight > Gatewaysの順に移動します。
-
ゲートウェイの詳細を表示する期間を選択します。タイムスライダーを使用して、選択した期間をさらにカスタマイズできます。Goをクリックします。
レポートのエクスポート
-
読み取り専用アクセス権を持つユーザーは、レポートをエクスポートできません。
-
地理マップレポートは、NetScaler Consoleにインターネット接続がある場合にのみエクスポートされます。
レポートをエクスポートするには
-
ダッシュボードタブの右ペインで、エクスポートボタンをクリックします。
-
今すぐエクスポートで、必要な形式を選択し、エクスポートをクリックします。
-
ダッシュボードタブの右ペインで、エクスポートボタンをクリックします。
-
エクスポートのスケジュールで、詳細を指定し、スケジュールをクリックします。
-
構成タブで、設定 > 通知 > メールに移動します。
-
右ペインで、メールサーバーを追加するにはメールサーバーを選択するか、メール配布リストを作成するにはメール配布リストを選択します。
-
詳細を指定し、作成をクリックします。
-
「ダッシュボード」タブの右ペインで、「エクスポート」ボタンをクリックします。
-
「今すぐエクスポート」の下で、「PDF」形式を選択し、「エクスポート」をクリックします。
Gateway Insight のユースケース
ユーザーが NetScaler Gateway アプライアンスまたは内部 Web サーバーにログインできない
-
認証
-
エンドポイント分析 (EPA)
-
シングルサインオン
認証の失敗
-
NetScaler Consoleで、Gateway > Gateway Insightに移動します。
-
概要セクションで、認証エラーを表示したい期間を選択します。タイムスライダーを使用して、選択した期間をさらにカスタマイズできます。Goをクリックします。

-
認証タブをクリックします。失敗グラフで、任意の時点での認証エラーの数を確認できます。

EPAの失敗
SSO障害
-
NetScaler Consoleで、Gateway > Gateway Insightに移動します。
-
概要セクションで、SSOエラーを表示したい期間を選択します。タイムスライダーを使用して、選択した期間をさらにカスタマイズできます。Goをクリックします。SSO失敗ビュー(/en-us/netscaler-application-delivery-management-software/media/use-cases-sso-failure-overview.png)
-
SSO (Single Sign On) タブをクリックします。失敗グラフで、任意の時点でのSSOエラーの数を確認できます。SSO失敗グラフ(/en-us/netscaler-application-delivery-management-software/media/use-cases-sso-failure-graph.png)
NetScaler Gatewayに正常にログオンした後、ユーザーが仮想アプリケーションを起動できない
-
NetScaler Consoleで、Gateway > Gateway Insightに移動します。
-
概要セクションで、SSOエラーを表示したい期間を選択します。タイムスライダーを使用して、選択した期間をさらにカスタマイズできます。Goをクリックします。アプリケーション起動失敗ビュー(/en-us/netscaler-application-delivery-management-software/media/use-cases-app-launch-failure-overview.png)
-
「Application Launch」タブをクリックします。「Failures」グラフで、任意の時点でのアプリケーション起動失敗の数を確認できます。アプリケーション起動失敗グラフ(/en-us/netscaler-application-delivery-management-software/media/use-cases-app-launch-failure-graph.png)
新しいアプリケーションを正常に起動した後、ユーザーはそのアプリケーションによって消費された合計バイト数と帯域幅を表示したいと考えています
ユーザーはNetScaler Gatewayに正常にログオンしましたが、内部ネットワーク内の特定のネットワークリソースにアクセスできません
-
ユーザーアクセス詳細(/en-us/netscaler-application-delivery-management-software/media/use-cases-resource-access.png)
異なるユーザーが異なるNetScaler Gateway展開を使用しているか、異なるアクセスモードでNetScaler Gatewayにログオンしている可能性があります。管理者は、展開タイプとアクセスモードに関する詳細を表示できる必要があります
-
Gateway Insight の概要(/en-us/netscaler-application-delivery-management-software/media/use-cases-deployment-types-access-modes-summary.png)Gateway Insight の概要グラフ(/en-us/netscaler-application-delivery-management-software/media/use-cases-deployment-types-access-modes-user-log-activity.png)

