ゲートウェイ インサイト
注意点
-
Gateway Insightは、次の展開でサポートされています。
-
アクセス ゲートウェイ
-
統合ゲートウェイ
-
-
NetScaler ADMのリリースとビルドは、NetScaler Gatewayアプライアンスのリリースとビルドと同じか、それ以降である必要があります。
-
Advancedライセンスを持つNetScalerインスタンスの場合、1時間分のGateway Insightレポートを表示できます。1時間を超えるGateway Insightレポートを表示するには、Premiumライセンスが必須です。
制限事項
-
認証方法が証明書ベースの認証として構成されている場合、NetScaler GatewayはGateway Insightをサポートしません。
-
Gateway Insightレポートの場合、NetScalerアプライアンスから地理位置情報が提供されません。
-
仮想ICAアプリケーションおよびデスクトップのユーザーログオンの成功、遅延、およびアプリケーションレベルの詳細は、HDX™ Insight Usersダッシュボードでのみ表示されます。
-
ダブルホップモードでは、第2DMZのNetScaler Gatewayアプライアンスでの障害の可視性は利用できません。
-
リモートデスクトッププロトコル (RDP) デスクトップアクセスに関する問題は報告されません。
-
Gateway Insightは、以下の認証タイプをサポートしています。これら以外の認証タイプが使用されている場合、Gateway Insightにいくつかの不一致が見られる可能性があります。
-
ローカル
-
LDAP
-
RADIUS
-
TACACS
-
SAML
-
ネイティブOTP
-
OAuth-OpenID コネクトOAuth-OpenID Connect認証の場合、NetScalerはOAuth-OpenID Connectリライングパーティ (RP) またはOAuth-OpenID Connectアイデンティティプロバイダー (IdP) として機能できます。認証が成功すると、ユーザー名はGateway Insightレポートのタブに報告されます。ただし、セッションがIdPまたはRPのどちらで作成されたかを特定することはできません。注: OAuth-OpenID Connect認証は、NetScaler ADMリリース13.1ビルド4.xx以降でサポートされています。
-
Gateway Insightを有効にする
-
Infrastructure > Instancesに移動し、AppFlowを有効にするインスタンスを選択します。
-
Select Actionリストから、Configure Analyticsを選択します。
-
Configure Insightページで、Configure Analyticsの下にあるNetScaler Gatewayを選択します。
-
仮想サーバーを選択し、Enable AppFlowをクリックします。
-
Enable AppFlow画面で、Select Expressionリストのtrueをクリックします。
-
Transport Modeの横にあるLogstreamチェックボックスをオンにします。注トランスポートモードとしてIPFIXまたはLogstreamのいずれかを選択できます。IPFIXとLogstreamの詳細については、Logstreamの概要(/ja-jp/netscaler-application-delivery-management-software/13-1/analytics/logstream.html)を参照してください。
-
OKをクリックします。
NetScaler ADMバージョン13.0 Build 41.x以降の場合
-
Infrastructure > Instancesに移動し、インスタンスを選択します。
-
「Select Action」リストから、「Configure Analytics」を選択します。
-
仮想サーバーを選択し、「Enable Analytics」をクリックします。
-
「Advanced Options」の下で:
-
「Logstream」を選択します。
-
「NetScaler Gateway」を選択します。
-
-
「OK」をクリックします。
GUI を使用して、NetScaler Gateway アプライアンスで AppFlow 認証、承認、および監査のユーザー名ログ記録を有効にする
-
Configuration > System > AppFlow > Settings に移動し、「Change AppFlow Settings」をクリックします。
-
「Configure AppFlow Settings」画面で、「AAA Username」を選択し、「OK」をクリックします。
Gateway Insight レポートの表示
EPA、SSO、認証、承認、およびアプリケーション起動の失敗を表示するには
-
NetScaler ADM で、Gateway > Gateway Insight に移動します。
-
ユーザーの詳細を表示したい期間を選択します。タイムスライダーを使用して、選択した期間をさらにカスタマイズできます。「Go」をクリックします。
-
失敗の詳細を表示するには、EPA (エンドポイント分析)、認証、承認、SSO (シングルサインオン)、またはアプリケーション起動のタブをクリックします。

セッションモード、クライアント、およびユーザー数の概要を表示するには

ユーザーの Gateway Insight レポートを表示する
-
NetScaler Gateway アプライアンスに関連付けられているすべてのユーザー。
-
ユーザーの EPA、認証、SSO、およびアプリケーション起動の失敗。
-
ユーザーのアクティブなセッションと終了したセッションの詳細。
-
フルトンネル、クライアントレス VPN、ICA® プロキシなどのセッションモードの種類。
ユーザーの詳細を表示するには
-
NetScaler ADM で、Gateway > Gateway Insight > Users に移動します。
-
ユーザーの詳細を表示したい期間を選択します。タイムスライダーを使用して、選択した期間をさらにカスタマイズできます。「Go」をクリックします。
-
その期間中にすべてのユーザーが使用したアクティブユーザー数、アクティブセッション数、バイト数、ライセンス数を表示できます。

-
ユーザー詳細 - ADC Gatewayアプライアンスに関連付けられている各ユーザーのインサイトを表示できます。「Gateway」>「Gateway Insight」>「Users」に移動し、ユーザーをクリックして、セッションモード、オペレーティングシステム、ブラウザなど、選択したユーザーのインサイトを表示します。

-
選択したゲートウェイのユーザーとアプリケーション - 「Gateway」>「Gateway Insight」>「Gateway」に移動し、ゲートウェイドメイン名をクリックして、選択したゲートウェイに関連付けられている上位10のアプリケーションと上位10のユーザーを表示します。

-
アプリケーションとユーザーのその他のオプションを表示 – 10を超えるアプリケーションとユーザーの場合、「Applications and Users」の「その他」アイコンをクリックすると、選択したゲートウェイに関連付けられているすべてのユーザーとアプリケーションの詳細を表示できます。
-
棒グラフをクリックして詳細を表示 – 棒グラフをクリックすると、関連する詳細を表示できます。たとえば、「Gateway > Gateway Insight > Gateway」に移動し、ゲートウェイの棒グラフをクリックしてゲートウェイの詳細を表示します。

-
ユーザーのアクティブセッションと終了セッション。

-
「Active Sessions」におけるゲートウェイドメイン名とゲートウェイIPアドレス。
-
ユーザーのログイン期間。Gateway Insight ログイン期間(/en-us/netscaler-application-delivery-management-software/media/gateway-insight-login-duration.png)
-
ユーザーのログアウトセッションの理由。ログアウトの理由は次のとおりです。
-
セッションがタイムアウトしました
-
内部エラーのためログアウトしました
-
非アクティブセッションのタイムアウトのためログアウトしました
-
ユーザーがログアウトしました
-
管理者がセッションを停止しました
-
アプリケーションのGateway Insightレポートの表示
アプリケーションの詳細を表示するには
-
NetScaler ADMで、Gateway > Gateway Insight > Applications に移動します。
-
アプリケーションの詳細を表示する期間を選択します。タイムスライダーを使用して、選択した期間をさらにカスタマイズできます。Go をクリックします。
ゲートウェイの Gateway Insight レポートの表示
ゲートウェイの詳細を表示するには
レポートのエクスポート
-
読み取り専用アクセス権を持つユーザーはレポートをエクスポートできません。
-
地図レポートは、NetScaler ADMにインターネット接続がある場合にのみエクスポートされます。
レポートをエクスポートするには
-
ダッシュボードタブの右側のペインで、エクスポートボタンをクリックします。
-
今すぐエクスポートで、必要な形式を選択し、エクスポートをクリックします。
-
ダッシュボードタブの右側のペインで、エクスポートボタンをクリックします。
-
エクスポートのスケジュールで、詳細を指定し、スケジュールをクリックします。
-
構成タブで、設定 > 通知 > メールに移動します。
-
右側のペインで、メールサーバーを追加するにはメールサーバーを選択し、メーリングリストを作成するにはメーリングリストを選択します。
-
詳細を指定し、作成をクリックします。
-
「ダッシュボード」タブの右ペインで、「エクスポート」ボタンをクリックします。
-
「今すぐエクスポート」で、「PDF」形式を選択し、「エクスポート」をクリックします。
Gateway Insight のユースケース
ユーザーが NetScaler Gateway アプライアンスまたは内部 Web サーバーにログインできない
-
認証
-
エンドポイント分析 (EPA)
-
シングルサインオン
認証の失敗
-
NetScaler ADMで、Gateway > Gateway Insightに移動します。
-
概要セクションで、認証エラーを表示したい期間を選択します。タイムスライダーを使用して、選択した期間をさらにカスタマイズできます。Goをクリックします。認証エラービュー(/en-us/netscaler-application-delivery-management-software/media/use-cases-auth-failure-overview.png)
-
認証タブをクリックします。失敗グラフで、任意の時点での認証エラーの数を確認できます。認証失敗グラフ(/en-us/netscaler-application-delivery-management-software/media/use-cases-auth-failure-graph.png)
EPAの失敗
-
クラシック式が設定されている場合にのみ、EPAの失敗が報告されます。
-
事前認証ポリシーまたは事後認証ポリシーで高度な式が設定されている場合、EPAの失敗は報告されません。
-
nFactor認証フローの要因の1つとしてEPAが設定されている場合、EPAの失敗は報告されません。
-
NetScaler ADMで、Gateway > Gateway Insightに移動します。
-
概要セクションで、EPAエラーを表示したい期間を選択します。タイムスライダーを使用して、選択した期間をさらにカスタマイズできます。Goをクリックします。EPAの失敗ビュー(/en-us/netscaler-application-delivery-management-software/media/use-cases-epa-failure-overview.png)
-
EPA (エンドポイント分析) タブをクリックします。失敗グラフで、任意の時点でのEPAエラーの数を確認できます。EPAの失敗グラフ(/en-us/netscaler-application-delivery-management-software/media/use-cases-epa-failure-graph.png)
SSOの失敗
-
NetScaler ADMで、Gateway > Gateway Insightに移動します。
-
「概要」セクションで、SSOエラーを表示する期間を選択します。タイムスライダーを使用して、選択した期間をさらにカスタマイズできます。Goをクリックします。

-
SSO (Single Sign On) タブをクリックします。「失敗」グラフで、任意の時点でのSSOエラーの数を表示できます。

NetScaler Gatewayへのログオンに成功した後、ユーザーが仮想アプリケーションを起動できない
-
NetScaler ADMで、Gateway > Gateway Insightに移動します。
-
概要セクションで、SSOエラーを表示する期間を選択します。タイムスライダーを使用して、選択した期間をさらにカスタマイズできます。Goをクリックします。

-
「Application Launch」タブをクリックします。「Failures」グラフで、任意の時点でのアプリケーション起動失敗の数を確認できます。

新しいアプリケーションを正常に起動した後、ユーザーはそのアプリケーションによって消費された合計バイト数と帯域幅を表示したいと考えています
ユーザーはNetScaler Gatewayに正常にログオンしましたが、内部ネットワーク内の一部のネットワークリソースにアクセスできません
-
NetScaler ADMで、Gateway > Gateway Insight > Applicationsに移動します。
-
表示された画面で下にスクロールし、Other Applicationsタブで、ユーザーがログオンできなかったアプリケーションを選択します。

-
下にスクロールすると、Usersテーブルに、そのアプリケーションにアクセスできるすべてのユーザーが表示されます。
異なるユーザーが異なるNetScaler Gateway展開を使用しているか、異なるアクセスモードでNetScaler Gatewayにログオンしている可能性があります。管理者は、展開タイプとアクセスモードに関する詳細を表示できる必要があります
-
NetScaler ADMで、Gateway > Gateway Insightに移動します。
-
Overviewセクションで下にスクロールすると、Session Mode、Operating Systems、Browsers、およびUser Logon Activityの各チャートに、ユーザーがログオンに使用したさまざまなセッションモード、クライアントの種類、および1時間ごとにログオンしたユーザー数が表示されます。

