たとえば、プライマリのCitrix Application Delivery Controller™ (ADC) インスタンスを交換またはアップグレードする必要がある場合など、フェイルオーバーを強制したい場合があります。プライマリインスタンスまたはセカンダリインスタンスのいずれかからフェイルオーバーを強制できます。プライマリインスタンスでフェイルオーバーを強制すると、プライマリがセカンダリになり、セカンダリがプライマリになります。強制フェイルオーバーは、プライマリインスタンスがセカンダリインスタンスがUPであることを判断できる場合にのみ可能です。
強制フェイルオーバーは伝播または同期されません。強制フェイルオーバー後の同期ステータスを表示するには、インスタンスのステータスを確認できます。
強制フェイルオーバーは、以下のいずれかの状況で失敗します。
-
スタンドアロンシステムでフェイルオーバーを強制する。
-
セカンダリインスタンスが無効または非アクティブである。セカンダリインスタンスが非アクティブ状態の場合、フェイルオーバーを強制するには、その状態がUPになるまで待つ必要があります。
-
セカンダリインスタンスがセカンダリのままになるように構成されている。
NetScalerインスタンスは、強制フェイルオーバーコマンドを実行したときに潜在的な問題が検出された場合、警告メッセージを表示します。メッセージには、警告をトリガーした情報が含まれ、続行する前に確認を求められます。
プライマリインスタンスまたはセカンダリインスタンスでフェイルオーバーを強制できます。
NetScaler ADMを使用してセカンダリNetScalerインスタンスへのフェイルオーバーを強制するには:
-
NetScaler Application Delivery Management (ADM) で、Infrastructure > Instances > NetScaler > VPX タブに移動し、インスタンスを選択します。
-
選択したインスタンスタイプの下にリストされているインスタンスから、HAセットアップのインスタンスを選択します。
-
Action メニューから、Force Failover を選択します。
-
Yes をクリックして、強制フェイルオーバーアクションを確認します。
