インスタンスとは、NetScaler Application Delivery Management (ADM) から検出、管理、監視したい NetScaler ADC アプライアンスまたは仮想アプライアンスのことです。これらのインスタンスを管理および監視するには、NetScaler ADM サーバーに追加する必要があります。ADM には、以下の NetScaler ADC アプライアンスおよび仮想アプライアンスを追加できます。
-
NetScaler インスタンス
-
NetScaler MPX
-
NetScaler VPX
-
NetScaler SDX
-
NetScaler CPX
-
NetScaler BLX
-
NetScaler Gateway インスタンス
インスタンスは、NetScaler ADM サーバーを初めてセットアップするとき、または後で追加できます。
NetScaler ADM は、通信に ADC インスタンスの NetScaler IP (NSIP) アドレスを使用します。ADM は、管理アクセスが有効になっているサブネット IP (SNIP) アドレスを持つ ADC インスタンスも検出できます。ADC インスタンスと ADM の間で開いている必要があるポートについては、「
ポート」を参照してください。
SNIP を使用して ADC HA ペアを追加する場合は、ADC HA ペアで独立ネットワーク構成 (INC) モードを有効にしてください。インスタンスの追加の詳細については、「
インスタンスの追加」を参照してください。
インスタンスを ADM サーバーに追加すると、サーバーは暗黙的に自身をインスタンスのトラップ宛先として追加し、インスタンスのインベントリを収集します。
次の図は、ADM がインスタンスを暗黙的に検出し、追加する方法を示しています。
図に示すように、NetScaler ADMによって以下の手順が暗黙的に実行されます。
-
NetScaler ADMは、インスタンスプロファイルの詳細を使用してインスタンスにログオンします。ADC NITROコールを使用して、ADMはインスタンスのライセンス情報を取得します。ライセンス情報に基づいて、インスタンスがADCインスタンスであるかどうか、およびADCプラットフォームのタイプ(たとえば、NetScaler MPX、NetScaler VPX、NetScaler SDX、NetScaler BLX、またはNetScaler Gateway)を判断します。インスタンスの検出に成功すると、ADMのデータベースに追加されます。
インスタンスプロファイルに正しい資格情報が含まれていない場合、この手順は失敗する可能性があります。NetScaler MPX、NetScaler VPX、NetScaler SDX、NetScaler BLX、およびNetScaler Gatewayインスタンスの場合、ライセンスがインスタンスに適用されていない場合も、この手順は失敗する可能性があります。
HTTPを使用すると、ライセンスがインスタンスに構成されていなくても、すべてのインスタンスをADMに追加できます。
-
ADMは、そのIPアドレスをインスタンス上のトラップ宛先リストに追加します。これにより、ADMはADCインスタンスで生成されたトラップを受信できます。
インスタンス上のトラップ宛先の数がトラップ宛先の最大制限を超えると、この手順は失敗する可能性があります。インスタンスの最大制限は20です。
-
ADMは、NITROリクエストを送信してインスタンスからインベントリを収集します。ホスト名、ソフトウェアバージョン、実行中および保存済みの構成、証明書の詳細、インスタンスに構成されているエンティティなどのインスタンスの詳細を収集します。
この手順は、ネットワークまたはファイアウォールの問題が原因で失敗する可能性があります。