非 INC モードでのルートモニタによるフェイルオーバーの制限

最終公開日 : Sep 25, 2026
非INCモードのHA構成では、両方のノードでルートモニターに障害が発生した場合、いずれかのノードがそれぞれのルートモニターで監視されているすべてのルートにアクセスできるようになるまで、180秒ごとにフェイルオーバーが発生します。
ただし、ノードの場合は、ノードの と パラメータを設定することで、特定の間隔のフェイルオーバー数を制限できます。いずれかの制限に達すると、それ以上フェイルオーバーは発生せず、そのノードでルートモニターに障害が発生しても、ノードはプライマリとして割り当てられます(ただし、ノードの状態はNOT UP)。プライマリとしてのHA状態とNOT UPとしてのノード状態のこの組み合わせは、スティックプライマリ状態と呼ばれます。
その後、ノードが監視対象のすべてのルートに到達できた場合、次の監視障害により、ノードの と パラメーターがリセットされ、 パラメーターで指定された時間が開始されます。
これらのパラメータは各ノードで独立して設定されるため、伝播も同期もされません。
フェイルオーバーの数を制限するためのパラメータ
  • 最大フリップ数 (最大フリップ)
    ルートモニターの障害が原因でフェイルオーバーが発生した場合、非INCモードのHAノードで、最大フリップ時間間隔内で許容されるフェイルオーバーの最大数。
  • 最大フリップ時間 (最大フリップ時間)
    ルートモニターの障害によるフェイルオーバーが、非 INC モードの HA のノードで許可される時間(秒単位)。
コマンドラインインターフェイスを使用してフェイルオーバーの数を制限するには
コマンドプロンプトで入力します。
  • set HA node [-maxFlips < positive_integer>] [-maxFlipTime <positive_integer>]
  • show HA node [< id>]
GUI を使用してフェイルオーバーの数を制限するには
  1. > に移動し、 タブでローカルノードを開きます。
  2. 次のパラメーターを設定します。
  • 最大フリップ数
  • 最大フリップ時間
    > set ha node -maxFlips 30 -maxFlipTime 60
    Done
    > sh ha node
    1) Node ID: 0
    IP: 10.102.169.82 (NS)
    Node State: UP
    Master State: Primary
    Fail-Safe Mode: OFF
    INC State: DISABLED
    Sync State: ENABLED
    Propagation: ENABLED
    Enabled Interfaces : 1/1
    Disabled Interfaces : None
    HA MON ON Interfaces : 1/1
    Interfaces on which heartbeats are not seen :None
    Interfaces causing Partial Failure:None
    SSL Card Status: NOT PRESENT
    Hello Interval: 200 msecs
    Dead Interval: 3 secs
    Node in this Master State for: 0:4:24:1 (days:hrs:min:sec)

    2) Node ID: 1
    IP: 10.102.169.81
    Node State: UP
    Master State: Secondary
    Fail-Safe Mode: OFF
    INC State: DISABLED
    Sync State: SUCCESS
    Propagation: ENABLED
    Enabled Interfaces : 1/1
    Disabled Interfaces : None
    HA MON ON Interfaces : 1/1
    Interfaces on which heartbeats are not seen : None
    Interfaces causing Partial Failure: None
    SSL Card Status: NOT PRESENT

    Local node information:
    Configured/Completed Flips: 30/0
    Configured Flip Time: 60
    Critical Interfaces: 1/1

    Done
Related information

スティッキプライマリステートの SNMP アラーム

ノードがスティッキプライマリになったときにアラートを受け取りたい場合は、高可用性セットアップのノードで HA-STICKY-PRIMARY SNMP アラームを有効にします。ノードがスティッキプライマリになると、トラップメッセージ(stickyPrimary(1.3.6.1.4.1.5951.1.0.138))を生成して警告し、設定されたすべての SNMP トラップ宛先に送信します。SNMPアラームとトラップ先の構成の詳細については、「 SNMPv1およびSNMPv2トラップを生成するようにCitrix ADCを構成する」を参照してください。

よくある質問

2つのNetScalerアプライアンスNS-1とNS-2を非INCモードで高可用性セットアップした例を考えてみましょう。両方のノードの最大フリップ数と最大フリップ時間は同じ値で設定されています。
次の表に、この例で使用されている設定の一覧を示します。
エンティティ 詳細
NS-1 の IP アドレス 10.102.173.211
NS-2 の IP アドレス 10.102.173.212
最大フリップ数 2
最大フリップ時間 200