非 INC モードでのルートモニタによるフェールオーバーの制限

最終公開日 : Sep 25, 2026
非 INC モードの HA 設定で、ルートモニタが両方のノードで失敗した場合、いずれかのノードがそれぞれのルートモニタによって監視されるすべてのルートに到達できるまで 180 秒ごとにフェールオーバーが発生します。
ただし、ノードに対して、ノードの \[最大反転数\] パラメータと \[最大反転時間\] パラメータを設定することで、特定の間隔でのフェイルオーバー回数を制限できます。いずれかの制限に達すると、フェールオーバーは発生しなくなり、そのノードでルートモニタが失敗しても、ノードはプライマリ(ただし、ノードの状態は NOT UP)として割り当てられます。NOT UPとしてプライマリとノード状態としてHA状態のこの組み合わせは、スティックプライマリ状態と呼ばれています。
ノードが監視対象のすべてのルートに到達できる場合、次の監視障害によって、ノードの \[最大反転数\] パラメータと \[最大フリップ時間\] パラメータがリセットされ、\[最大フリップ時間\] パラメータで指定された時間が開始されます。
これらのパラメータは、各ノードで個別に設定されるため、伝播も同期もされません。
フェイルオーバー数を制限するためのパラメータ
  • フリップの最大数 (最大フリップ)
    ルートモニタの障害が原因でフェールオーバーが発生した場合、非 INC モードの HA ノードの Maximum Flip Time インターバル内で許容されるフェールオーバーの最大数。
  • 最大反転時間 (最大反転時間)
    非 INC モードの HA ノードで、ルートモニタの障害に起因するフェールオーバーが許可される時間(秒単位)。
コマンドラインインターフェイスを使用してフェールオーバーの数を制限するには
コマンドプロンプトで入力します。
  • set HA node [-maxFlips < positive_integer>] [-maxFlipTime <positive_integer>]
  • show HA node [< id>]
GUI を使用してフェールオーバーの数を制限するには
  1. \[システム\] > \[高可用性\] に移動し、\[ノード\] タブでローカルノードを開きます。
  2. 次のパラメーターを設定します。
  • フリップの最大数
  • 最大フリップ時間
    > set ha node -maxFlips 30 -maxFlipTime 60
    Done
    > sh ha node
    1) Node ID: 0
    IP: 10.102.169.82 (NS)
    Node State: UP
    Master State: Primary
    Fail-Safe Mode: OFF
    INC State: DISABLED
    Sync State: ENABLED
    Propagation: ENABLED
    Enabled Interfaces : 1/1
    Disabled Interfaces : None
    HA MON ON Interfaces : 1/1
    Interfaces on which heartbeats are not seen :None
    Interfaces causing Partial Failure:None
    SSL Card Status: NOT PRESENT
    Hello Interval: 200 msecs
    Dead Interval: 3 secs
    Node in this Master State for: 0:4:24:1 (days:hrs:min:sec)

    2) Node ID: 1
    IP: 10.102.169.81
    Node State: UP
    Master State: Secondary
    Fail-Safe Mode: OFF
    INC State: DISABLED
    Sync State: SUCCESS
    Propagation: ENABLED
    Enabled Interfaces : 1/1
    Disabled Interfaces : None
    HA MON ON Interfaces : 1/1
    Interfaces on which heartbeats are not seen : None
    Interfaces causing Partial Failure: None
    SSL Card Status: NOT PRESENT

    Local node information:
    Configured/Completed Flips: 30/0
    Configured Flip Time: 60
    Critical Interfaces: 1/1

    Done
Related information

スティッキプライマリステートの SNMP アラーム

ノードがスティッキプライマリになることを警告する場合は、高可用性セットアップのノードで HA-STICKY-PRIMARY SNMP アラームを有効にします。ノードがスティッキプライマリになると、トラップメッセージ(stickyPrimary(1.3.6.1.4.1.5951.1.0.138))を生成して警告し、設定されたすべての SNMP トラップ宛先に送信します。SNMPアラームとトラップ先の構成の詳細については、「 SNMPv1およびSNMPv2トラップを生成するようにCitrix ADCを構成する」を参照してください。

よくある質問

2つのCitrix ADCアプライアンスNS-1とNS-2を非INCモードで高可用性セットアップする例を考えてみましょう。両方のノードでフリップの最大数と最大フリップ時間が同じ値で設定されています。
次の表に、この例で使用される設定を示します。
エンティティ 詳細
NS-1のIPアドレス 10.102.173.211
NS-2のIPアドレス 10.102.173.212
フリップの最大数 2
最大フリップ時間 200