ドメイン・ネーム・システムのセキュリティ拡張

最終公開日 : Sep 25, 2026
DNS Security Extensions(DNSSEC)は、インターネット技術特別調査委員会(IETF)の標準です。これは、UDP応答をクリアテキストで送信しながら、ネームサーバーとクライアント間の通信でデータの整合性とデータ発信元の認証を提供することを目的としています。DNSSEC は、非対称キー暗号を使用するメカニズムと、その実装に固有の新しいリソースレコードのセットを指定します。
DNSSEC仕様は次のとおりです。
  • RFC 4033、「DNSセキュリティの概要と要件」
  • RFC 4034、「DNSセキュリティ拡張機能のリソースレコード」
  • RFC 4035、「DNSセキュリティ拡張機能のプロトコル変更」
DNS 内で DNSSEC を実装する際の運用面については、RFC 4641「DNSSEC 運用慣行」で説明しています。
DNSSECは、Citrix ADC上で構成することができます。DNS ゾーンに署名するためのキーを生成およびインポートできます。Citrix ADCが権限を持つゾーンに対してDNSSECを構成できます。バックエンドネームサーバーのファームでホストされている署名付きゾーンのDNSプロキシサーバーとしてADCを構成できます。ADC が DNS プロキシサーバーとして構成されているゾーンに属するレコードのサブセットに対して権限がある場合は、DNSSEC 実装にレコードのサブセットを含めることができます。