電話会社の加入者管理
-
加入者ポリシーの適用と管理。
-
完全な IPv6 アドレスではなく IPv6 プレフィクスのみを使用して、サブスクライバを一意に識別するようにアプライアンスを設定します。
-
ポリシーを使用して、ダイナミックサブスクライバとスタティックサブスクライバの両方の TCP トラフィックを最適化します。これらのポリシーは、異なる TCP プロファイルを異なるタイプのユーザに関連付けます。
-
Citrix ADCアプライアンスでアイドル状態のセッションを管理します。
-
ログサーバへのロギングを有効にします。
-
削除されたサブスクライバセッションの LSN セッションを削除します。
サブスクライバセッションストアモジュールへのメモリの割り当て
例
show extendedmemoryparam
Extended Memory Global Configuration. This memory is utilized by LSN and Subscriber Session Store Modules:
Active Memory Usage: 0 MBytes
Configured Memory Limit: 0 MBytes
Minimum Memory Required: 2058 MBytes
Maximum Memory Usage Limit: 2606 MBytes
Done
set extendedmemoryparam -memLimit 2558
Done
show extendedmemoryparam
Extended Memory Global Configuration. This memory is utilized by LSN and Subscriber Session Store Modules:
Active Memory Usage: 2558 MBytes
Configured Memory Limit: 2558 MBytes
Minimum Memory Required: 2058 MBytes
Maximum Memory Usage Limit: 2606 MBytes
Done
ダイナミックサブスクライバ用のインターフェイスの設定
-
NetScaler リリース12.0ビルド57.19以降、クラスタ展開ではGxインターフェイスがサポートされます。詳細については、 クラスタトポロジの Gx インターフェイスを参照してください。
-
HA セットアップでは、サブスクライバセッションはセカンダリノードで継続的に同期されます。フェールオーバーが発生しても、サブスクライバ情報はセカンダリノードで引き続き使用できます。
Gx インターフェイス
Gx インターフェイスを設定するには、次の作業を実行します
add service pcrf-svc1 203.0.113.1 DIAMETER 3868
add service pcrf-svc2 203.0.113.2 DIAMETER 3868
add lb vserver vdiam DIAMETER 0.0.0.0 0 -persistenceType DIAMETER -persistAVPno 263
bind lb vserver vdiam pcrf-svc1
bind lb vserver vdiam pcrf-svc2
set ns diameter –identity netscaler.com –realm com
set subscriber gxInterface -vServer vdiam -pcrfRealm pcrf.com
set subscriber param -interfaceType GxOnly
show subscriber gxinterface
例
show subscriber gxinterface
Gx Interface parameters:
PCRF Vserver: vdiam (DOWN)
Gx Client Identity...: netscaler1.com
Gx Client Realm ..........: com
PCRF Realm: epc.mnc030.mcc234.3gppnetwork.org
Hold Packets On Subscriber Absence: YES
CCR Request Timeout: 4 Seconds
CCR Request Retry Attempts: 1
Gx HealthCheck enabled: NO
Gx HealthCheck TTL : 30 Seconds
CER Request Timeout: 10 Seconds
RevalidationTimeout: 30 Seconds
NegativeTTL: 60 Seconds
NegativeTTL Limited Success: NO
Purge SDB on Gx Failure: YES
ServicePath AVP code: 262099 ServicePath AVP VendorID: 3845
PCRF Connection State: PCRF is not ready
Done
ARGUMENTS
仮想サーバー
サービス
pcrfレルム
加入者不在に保留します
要求タイムアウト
要求再試行回数
ヘルスチェック
healthCheckTTL
cerRequestTimeout
再検証タイムアウト
negativeTTL
negativeTTLLimitedSuccess
purgeSDBonGxFailure
servicePathAVP
servicePathVendorid
GUI を使用して Gx インターフェイスを設定するには
-
Traffic Management > Subscriber > Parametersに移動します。
-
\[ サブスクライバーパラメータの構成\]をクリックします。
-
\[インタフェースの種類\] で、\[ GxOnly\] を選択します。
-
必要なすべてのパラメータの値を指定します。
-
[OK] をクリックします。
確立された Gx 接続でのトランスポート障害の検出
-
DWA を受信すると、ピアの可用性が確認され、ウォッチドッグタイマーがリセットされます。
-
DWA が受信されず、ウォッチドッグタイマーが連続して 2 回期限切れになると、セッションはダウンし、ピアが利用できないと見なされます。アプライアンスはセッションを閉じ、Gx ピアとの新しいセッションを確立しようとします。
CLI を使用して、確立された Gx 接続を介したトランスポート障害を検出するには
set subscriber gxInterface [-vServer <string>] [-service <string>] [-healthCheck ( YES | NO )] [-healthCheckTTL<positive_integer>][-cerRequestTimeout <positive_integer>] [-purgeSDBonGxFailure ( YES | NO )]
set subscriber gxInterface set subscriber gxInterface -vServer vdiam -healthCheck YES -healthCheckTTL 31 -cerRequestTimeout 15 purgeSDBonGxFailure YES
GUIを使用して確立されたGx接続を介したトランスポート障害を検出するには
-
Traffic Management > Subscriber > Parametersに移動します。
-
\[ サブスクライバーパラメータの構成\]をクリックします。
-
\[ インターフェイスタイプ\]で、\[ GxOnly\]を選択します。
-
すべての必須パラメータの値を指定します。
-
\[ヘルスチェック\] を選択し、\[ヘルスチェック TTL\] および \[CER 要求タイムアウト\] の値を指定します。
-
[OK] をクリックします。
クラスタトポロジの Gx インターフェイス
-
CCR-I 要求を PCRF サーバに送信し、サブスクライバ情報を取得します。
-
PCRF サーバは、CCR-A で応答します。
-
次に、Citrix ADCノードは、受信したサブスクライバ情報をサブスクライバストアに保存し、ルールをクライアントトラフィックに適用します。
GUI を使用して直径パラメータを設定するには
-
\[ システム \] > \[ **設定\]**に移動します。
-
詳細ウィンドウで、\[直径パラメータを変更\] をクリックします。
-
\[直径パラメータ\] ページで、直径パラメータを設定するCitrix ADCノードを選択し、\[構成\] をクリックします。
-
「直径パラメータの構成」ページで、選択したノードの直径のアイデンティティ、直径レルム、およびサーバークローズ伝播を構成します。
-
[OK] をクリックします。
CLI を使用して直径パラメータを設定するには
set ns diameter [-identity <string>] [-ownerNode <positive_integer>]
ARGUMENTS
ID
OwnerNode
show diameter -ownerNode <0-31>
クラスター展開用に Gx インターフェイスを構成するには
add service pcrf-svc1 203.0.113.1 DIAMETER 3868
add service pcrf-svc2 203.0.113.2 DIAMETER 3868
add lb vserver vdiam DIAMETER 0.0.0.0 0 -persistenceType DIAMETER -persistAVPno 263
bind lb vserver vdiam pcrf-svc1
bind lb vserver vdiam pcrf-svc2
set ns diameter -identity node0.netscaler.com -realm netscaler.com -ownerNode 0
set ns diameter -identity node1.netscaler.com -realm netscaler.com -ownerNode 1
set subscriber gxInterface -vServer vdiam -pcrfRealm pcrf.com
Set the subscriber interface type to GxOnly.
set subscriber param -interfaceType GxOnly
show subscriber gxinterface
RADIUS インターフェイス
add service srad1 192.0.0.206 RADIUSLISTENER 1813
set subscriber radiusInterface -listeningService srad1
set subscriber param -interfaceType RadiusOnly
add radius client 192.0.2.0/24 -radkey client123
show subscriber radiusInterface
add service pcrf-svc1 203.0.113.1 DIAMETER 3868
add service pcrf-svc2 203.0.113.2 DIAMETER 3868
ARGUMENTS
ListeningService
svrState
GUI を使用して RadiusOnly インターフェイスを設定するには
-
Traffic Management > Subscriber > Parametersに移動します。
-
\[ サブスクライバーパラメータの構成\]をクリックします。
-
\[インタフェースタイプ\] で、\[RadiusOnly\] を選択します。
-
必要なすべてのパラメータの値を指定します。
-
[OK] をクリックします。
RADIUS および Gx インターフェイス
set subscriber param -interfaceType RadiusandGx
add service pcrf-svc 203.0.113.1 DIAMETER 3868
add lb vserver vdiam DIAMETER 0.0.0.0 0 -persistenceType DIAMETER -persistAVPno 263
bind lb vserver vdiam pcrf-svc
set subscriber gxInterface -vServer vdiam -pcrfRealm testrealm1.net -holdOnSubscriberAbsence YES -revalidationTimeout 60 -negativeTTL 120
add service srad1 192.0.0.206 RADIUSLISTENER 1813 set subscriber radiusInterface -listeningService srad1
GUI を使用して RadiusAndGx インターフェイスを設定するには
-
Traffic Management > Subscriber > Parametersに移動します。
-
\[ サブスクライバーパラメータの構成\]をクリックします。
-
「インタフェース・タイプ」で、「 RadiusAndGx」を選択します。
-
必要なすべてのパラメータの値を指定します。
-
[OK] をクリックします。
スタティックサブスクライバの設定
add subscriber profile 203.0.113.6 -subscriberRules policy1 policy2 -subscriptionIdType E164 -subscriptionIdvalue 98767543211
add subscriber profile 2002::a66:e8d3/64 -subscriberRules policy1 policy3 -subscriptionIdtype E164 -subscriptionIdvalue 98767543212
add subscriber profile 203.0.24.2 10 -subscriberRules policy2 policy3 -subscriptionIdtype E164 -subscriptionIdvalue 98767543213
> show subscriber profile
1) Subscriber IP: 203.0.24.2 VLAN:10
Profile Attributes:
Active Rules: policy2, policy3
Subscriber Id Type: E164
Subscriber Id Value: 98767543213
2) Subscriber IP: 2002::/64
Profile Attributes:
Active Rules: policy1, policy3
Subscriber Id Type: E164
Subscriber Id Value: 98767543212
3) Subscriber IP: 203.0.113.6
Profile Attributes:
Active Rules: policy1, policy2
Subscriber Id Type: E164
Subscriber Id Value: 98767543211
Done
デフォルトの加入者プロファイル
> add subscriber profile * -subscriberRules policy1
加入者セッションの表示とクリア
> show subscriber sessions
1) Subscriber IP: 2002::/64
Session Attributes:
Active Rules: policy1, policy3
Subscriber Id Type: E164
Subscriber Id Value: 98767543212
2) Subscriber IP: *
Session Attributes:
Active Rules: policy1
3) Subscriber IP: 203.0.24.2 VLAN:10
Session Attributes:
Active Rules: policy2, policy3
Subscriber Id Type: E164
Subscriber Id Value: 98767543213
4) Subscriber IP: 203.0.113.6
Session Attributes:
Active Rules: policy1, policy2
Subscriber Id Type: E164
Subscriber Id Value: 98767543211
5) Subscriber IP: 192.168.0.11
Session Attributes:
Idle TTL remaining: 361 Seconds
Active Rules: policy1
Subscriber Id Type: E164
Subscriber Id Value: 1234567811
Service Path: policy1
AVP(44): 34 44 32 42 42 38 41 43 2D 30 30 30 30 30 30 31 31
AVP(257): 00 01 C0 A8 0A 02
PCRF-Host: host.pcrf.com
AVP(280): 74 65 73 74 2E 63 6F 6D
Done
clear subscriber sessions <ip>
加入者ポリシーの適用および管理システム
add responder action error_msg respondwith '"HTTP/1.1 403 OKrnrn" + " You are not authorized to access Internet"'
add responder policy no_internet_access "SUBSCRIBER.RULE_ACTIVE("pol1")" error_msg
> add rewrite action AddHDR-act insert_http_header X-Nokia-MSISDN "SUBSCRIBER.AVP(45).VALUE"
> add rewrite policy AddHDR-pol "HTTP.REQ.HOSTNAME.APPEND(HTTP.REQ.URL).EQUALS_ANY("patset-test")" AddHDR-act
> add cache policy nocachepol -rule "SUBSCRIBER.RULE_ACTIVE("cache_disable")" - action NOCACHE
> add cache policy cachepol -rule "SUBSCRIBER.RULE_ACTIVE("cache_enable")" - action CACHE -storeInGroup cg1
IPv6 プレフィクスベースのサブスクライバセッション
コマンドラインを使用して IPv6 プレフィックスを構成するには
set subscriber param [-ipv6PrefixLookupList <positive_integer> ...]
set subscriber param -ipv6PrefixLookupList 64
set subscriber param -ipv6PrefixLookupList 64 72 96
構成ユーティリティを使用して IPv6 プレフィックスを構成するには
-
Traffic Management > Subscriber > Parametersに移動します。
-
詳細ペインの \[設定\] で、\[サブスクライバパラメータの設定\] をクリックし、\[IPv6 プレフィクスルックアップリスト\] で 1 つまたは複数のプレフィクスを指定します。
IP アドレスおよび VLAN ID キーの検索方法
-
IPv4 サブスクライバの Gx クエリに発信元 VLAN ID を含めます。
-
すべての Gx 応答に Gx VLAN AVP を含めます。ただし、VLAN ID の不一致がある場合、アプライアンスは応答を無視します。
-
インターフェイスタイプ RadiusAndGx および RadiusOnly は、キータイプ IPANDVLAN とともに設定できません。
-
IPv6アドレスからのトラフィックの場合、Citrix ADCアプライアンスはIPルックアップ方式を使用します。
CLI を使用して IP または IPANDVLAN をキールックアップ方式として設定するには
set subscriber param [-keytype ( IP | IPANDVLAN )] [-interfaceType <interfaceType>]
set subscriber param -keytype IPANDVLAN -interfaceType GxOnly
set subscriber param -keytype IP -interfaceType GxOnly
VLAN パラメータ
add subscriber profile <ip>@ [-vlan]
set subscriber profile <ip>@ [-vlan] [-subscriptionIdType <subscriptionIdType>]
show subscriber profile [<ip>@] [-vlan]
rm subscriber profile <ip>@ [-vlan <positive_integer>]
引数
IP
vlan
add subscriber profile 192.0.2.23 10
set subscriber profile 192.0.2.23 10 -subscriptionIdtype E164
show subscriber profile 192.0.2.23 10
rm subscriber profile 192.0.2.23 10
GUI を使用して IP または IPANDVLAN をキールックアップ方式として設定するには
-
\[ トラフィック管理 \] > \[ 加入者 \] > \[ パラメータ\] に移動します。
-
\[ サブスクライバパラメータの設定\] をクリックします。
-
\[キーの種類\] で、要件に応じて \[IP\] または \[IPANDVLAN\] を選択します。
-
構成を完了し、\[OK\] をクリックします。
Telco ネットワークにおける加入者セッションのアイドルセッション管理
コマンドラインを使用してアイドルセッションタイムアウトおよび関連付けられたアクションを構成するには
set subscriber param [-idleTTL <positive_integer>] [-idleAction <idleAction>]
set subscriber param -idleTTL 3600 -idleAction ccrTerminate
set subscriber param -idleTTL 3600 -idleAction ccrUpdate
set subscriber param -idleTTL 3600 -idleAction delete
構成ユーティリティを使用してアイドルセッションタイムアウトおよび関連するアクションを構成するには
-
Traffic Management > Subscriber > Parametersに移動します。
-
詳細ペインの \[設定\] で、\[サブスクライバパラメータの構成\] をクリックし、\[アイドル時間\] と \[アイドルアクション\] を指定します。
サブスクライバセッションイベントロギング
-
Session Event (Install, Update, Delete, Error)
-
Gx Message Type (CCR-I, CCR-U, CCR-T, RAR)
-
Radius Message Type (Start, Stop)
-
サブスクライバ IP
-
サブスクライバ ID タイプ (MSISDN (E164)、IMSI)
-
サブスクライバ ID 値
> add syslogAction sysact1 192.0.2.0 -loglevel EMERGENCY ALERT CRITICAL ERROR WARNING NOTICE INFORMATIONAL -subscriberlog enabled
-
次のログエントリは、RADIUSandGx セッションの作成、セッションの更新、およびセッションの削除の例です。09/30/2015:16:29:18 GMT Informational 0-PPE-0 : default SUBSCRIBER SESSION_EVENT 147 0 : Session Install, GX MsgType: CCR-I, RADIUS MsgType: Start, IP: 100.10.1.1, ID: E164 - 3000000000109/30/2015:16:30:18 GMT Informational 0-PPE-0 : default SUBSCRIBER SESSION_EVENT 148 0 : Session Update, GX MsgType: CCR-U, IP: 100.10.1.1, ID: E164 - 3000000000109/30/2015:17:27:56 GMT Informational 0-PPE-0 : default SUBSCRIBER SESSION_EVENT 185 0 : Session Delete, GX MsgType: CCR-T, RADIUS MsgType: Stop, IP: 100.10.1.1, ID: E164 - 30000000001
-
次のログエントリは、PCRF サーバでサブスクライバが見つからない場合や、アプライアンスが PCRF サーバに接続できない場合など、エラーメッセージの例です。09/30/2015:16:44:15 GMT Error 0-PPE-0 : default SUBSCRIBER SESSION_FAILURE 169 0 : Failure Reason: PCRF failure response, GX MsgType: CCR-I, IP: 100.10.1.1Sep 30 13:03:01 09/30/2015:16:49:08 GMT 0-PPE-0 : default SUBSCRIBER SESSION_FAILURE 176 0 : Failure Reason: Unable to connect to PCRF, GX MsgType: CCR-I, RADIUS MsgType: Start, IP: 100.10.1.1, ID: E164 - 30000000001#000#000#000#000#000#000#000#000#000#000#000#000#000#000#000#000
Subscriber aware LSN session termination
CLI を使用して加入者認識 LSN セッション終了を設定するには
> set lsn parameter -subscrSessionRemoval ENABLED
Done
> sh lsn parameter
LSN Global Configuration:
Active Memory Usage: 0 MBytes
Configured Memory Limit: 0 MBytes
Maximum Memory Usage Limit: 912 MBytes
Session synchronization: ENABLED
Subscriber aware session removal: ENABLED
GUI を使用して加入者認識 LSN セッション終了を設定するには
-
\[システム\] > \[大規模NAT\] に移動します。
-
\[はじめに\] で、\[LSN パラメータの設定\] をクリックします。
-
サブスクライバ認識セッションの削除パラメータを設定します。
トラブルシューティング
-
show subscriber gxinterface このコマンドの出力には、次のエラーメッセージ(ここに示される応答を示します)を含めることができます。
-
Gx インターフェイスが設定されていない-set subscriber param コマンドを使用して、正しいインターフェイスタイプを設定します。
-
PCRF が設定されていない-GxInterface上で直径 vServer またはサービスを設定する-set subscriber gx インターフェイスコマンドを使用して、このインターフェイスに Diameter 仮想サーバまたはサービスを割り当てます。
-
PCRF の準備ができていません。詳細については、対応する仮想サーバ/サービスを確認してください。サービスの状態を確認するには、show LB vserver または show service コマンドを使用します。
-
Citrix ADCは、PCRFとCitrix ADC間のPCRF機能ネゴシエーションからのCEAを待機しています。これは断続的な状態である可能性があります。問題が解決しない場合は、PCRFサーバーの直径設定を確認してください。
-
サブスクライバセッションを保存するようにメモリが設定されていません。拡張メモリを構成するには、「拡張メモリを設定」を使用してください。拡張メモリを構成するには、set 拡張メモリパラメータを使用します。
-
-
show subscriber radiusinterface "Not Configured"の場合は、set subscriber radiusinterface コマンドを使用して、RADIUSListener サービスを指定します。