GSLB 仮想サーバーの構成

最終公開日 : Sep 25, 2026
GSLB 仮想サーバーは、1 つ以上の GSLB サービスを表し、それらの間のトラフィックのバランスをとるエンティティです。設定された GSLB メソッドまたはアルゴリズムを評価して、クライアント要求を送信する GSLB サービスを選択します。
注
GSLB仮想サーバープロトコルの要件は、主に仮想サーバーと仮想サーバーにバインドされているサービスの間の関係を作成することです。これにより、CLI/API が他のタイプの仮想サーバに対して一貫性が保たれます。サービスまたは仮想サーバーの Service Type パラメーターは、DNS 要求の処理中には使用されません。代わりに、サイトの永続性、モニタリング、および MEP を介したルックアップの実行中に参照されます。

コマンドラインインターフェイスを使用して GSLB 仮想サーバーを作成するには

コマンドプロンプトで次のコマンドを入力して、GSLB 仮想サーバーを追加し、構成を確認します。
-  add gslb vserver <name> <serviceType> -ipType (IPv4 | IPv6)
-  show gslb vserver <name>
例:
add gslb vserver Vserver-GSLB-1 HTTP -ipType IPv4
add gslb vserver Vserver-GSLB-2 HTTP -ipType IPv6
show gslb vserver Vserver-GSLB-1
show gslb vserver Vserver-GSLB-2

コマンドラインインターフェイスを使用して GSLB 仮想サーバーを変更または削除するには

  • GSLB 仮想サーバーを変更するには、set gslb vserver コマンドを使用します。このコマンドはadd gslb vserverコマンドと似ていますが、既存の GSLB 仮想サーバーの名前を入力する点が異なります。
  • パラメータをデフォルト値にリセットするには、unset gslb vserver コマンドの後に vserverName 値、および設定解除するパラメータの名前を指定します。
  • GSLB 仮想サーバーを削除するには、name 引数だけを受け付けるrm gslb vserver コマンドを使用します。

構成ユーティリティを使用して GSLB 仮想サーバーを構成するには

  1. \[トラフィック管理\] > \[GSLB\] > \[仮想サーバー\] に移動します。
  2. 新しい GSLB 仮想サーバーを追加するか、既存の GSLB 仮想サーバーを選択してその設定を編集します。

コマンドラインインターフェイスを使用して GSLB 仮想サーバーの統計情報を表示するには

コマンドプロンプトで入力します。
stat gslb vserver <name>
例:
stat gslb vserver Vserver-GSLB-1

構成ユーティリティを使用して GSLB 仮想サーバーの統計情報を表示するには

\[トラフィック管理\] > \[GSLB\] > \[仮想サーバー\] に移動し、仮想サーバーを選択して \[統計\] をクリックします。

GSLB 仮想サーバの統計情報

Citrix ADC バージョン 12.1 ビルド 51.xx 以降から、GSLB 仮想サーバーの統計情報には、vserver ヒット、現在の永続性セッション、要求バイト、応答バイト、スピルオーバーしきい値、スピルオーバーヒット、現在のクライアント確立などの詳細情報も表示されます。接続、および vserver のバックアップヒットがダウンします。
  • プライマリ LB メソッドの失敗: プライマリ GSLB メソッドが失敗した回数。
  • バックアップ LB メソッドの失敗: バックアップ GSLB メソッドが失敗した回数。
  • Vserver パーシステンスヒット:パーシスタンスセッションを通じてリクエストが処理された回数。
GSLB 仮想サーバーの統計情報には、仮想サーバーにバインドされたサービスグループメンバーの統計情報も表示されます。
注: プライマリ方式が静的な近接方式で、バックアップ方式が RTT の場合、プライマリ方式またはバックアップ方式が失敗する可能性があります。このシナリオでは、LDNS IP に対応するロケーションがない場合、スタティック近接は失敗し、バックアップ方法が試行されます。統計は、以下に基づいて更新されます。
  • バックアップ方式が成功した場合、プライマリ方式の障害統計情報だけが増分されます。
  • RTT 計算が成功しなかった場合、バックアップ方法も失敗します。この場合、プライマリ方式とバックアップ方式の障害統計の両方が増加します。
バックアップ方法が失敗した場合は、最後の手段としてラウンドロビンが使用されます。
次の図は、CLI からの GSLB 仮想サーバーの統計情報のサンプルです。
GSLB 仮想サーバの統計情報
次の図は、GUIからのGSLB仮想サーバー統計のサンプルです。
GSLB 仮想サーバの統計情報

GSLB サービスの統計情報

コマンドラインから stat gslb service コマンドを実行するか、構成ユーティリティから \[Statistics\] リンク をクリックすると、サービスの次の詳細が表示されます。
  • **要求バイト数。**このサービスまたは仮想サーバで受信した要求バイトの合計数。
  • **応答バイト数。**このサービスまたは仮想サーバが受信した応答バイト数。
  • **現在のクライアントが接続を確立しました。**ESTABLISHED 状態のクライアント接続の数。
  • **サービスの現在の負荷。**サービスの負荷(サービスにバインドされた負荷モニターから計算)。
要求と応答の数、および現在のクライアントとサーバーの接続数のデータが表示されないか、対応する負荷分散仮想サーバーのデータと同期されないことがあります。

GSLB 仮想サーバーまたはサービス統計情報のクリア

注:この機能は、NetScaler リリース10.5.eで使用できます。
GSLB 仮想サーバーおよびサービスの統計情報をクリアできるようになりました。Citrix ADCには、統計情報をクリアするための次の2つのオプションがあります。
  • 基本: 仮想サーバーに固有の統計をクリアしますが、バインドされた GLSB サービスによって提供された統計は保持します。
  • [完全]:仮想サーバーとバインドされたGSLBサービス統計の両方をクリアします。

コマンドラインインターフェイスを使用して GSLB 仮想サーバーの統計情報をクリアするには

コマンドプロンプトで入力します。
stat gslb vserver <name> -clearstats <basic | full>
例:
stat gslb vserver Vserver-GSLB-1 –clearstats basic

コマンドラインインターフェイスを使用して GSLB サービスの統計情報をクリアするには

コマンドプロンプトで入力します。
stat gslb service <name> -clearstats <basic | full>
例:
stat gslb service service-GSLB-1 –clearstats basic

構成ユーティリティを使用して GSLB 仮想サーバーの統計情報を消去するには

  1. \[トラフィック管理\] > \[GSLB\] > \[仮想サーバー\] に移動します。
  2. GSLB 仮想サーバーを選択し、\[統計\] をクリックし、\[クリア\] をクリックします。
  3. \[クリア\] ドロップダウンリストから、\[基本\] または \[完全\] を選択し、\[OK\] をクリックします。

構成ユーティリティを使用して GSLB サービスの統計情報を消去するには

  1. Traffic Management > GSLB > Servicesに移動します。
  2. GSLB サービスを選択し、\[統計\] をクリックし、\[クリア\] をクリックします。
  3. \[クリア\] ドロップダウンリストから、\[基本\] または \[完全\] を選択し、\[OK\] をクリックします。

GSLB 仮想サーバーの有効化と無効化

GSLB 仮想サーバーを作成すると、デフォルトで有効になります。GSLB仮想サーバーを無効にした場合、DNS要求を受信すると、Citrix ADCアプライアンスは構成されているGSLB方式に基づいてGSLB決定を行いません。代わりに、DNS クエリへの応答には、仮想サーバーにバインドされているすべてのサービスの IP アドレスが含まれます。

コマンドラインインターフェイスを使用して GSLB 仮想サーバーを有効または無効にするには

コマンドプロンプトで、次のコマンドのいずれかを入力します。
enable gslb vserver <name>@  

disable gslb vserver <name>@  
例:
enable gslb vserver Vserver-GSLB-1
disable gslb vserver Vserver-GSLB-1

構成ユーティリティを使用して GSLB 仮想サーバーを有効または無効にするには

  1. \[トラフィック管理\] > \[GSLB\] > \[仮想サーバー\] に移動します。
  2. 仮想サーバを選択し、[アクション]リストから[有効]または[無 効]を選択します。