バックアップ仮想サーバを持たない負荷分散仮想サーバは、バインドされたサービスの状態および管理上の無効化かどうかに応じて、次の状態になります。
-
UP: 仮想サーバーにバインドされているサービスの少なくとも 1 つが UP 状態です。
-
DOWN: 仮想サーバーにバインドされているすべてのサービスがダウンしているか、負荷分散機能が有効になっていません。
-
アウトオブサービス (OFS): 仮想サーバーを管理上無効にすると、OFS 状態になりますが、有効状態は DOWN です。管理者は、OFS 状態への移行を DOWN または UP 状態から、または OFS 状態から DOWN または UP 状態への移行を制御できます。
バックアップ仮想サーバが構成されていない場合、仮想サーバの状態と有効状態は同じです。ただし、バックアップ仮想サーバまたはバックアップ仮想サーバのチェーンが設定されている場合、有効状態は、プライマリ仮想サーバとバックアップ仮想サーバにバインドされているサービスの状態から得られます。チェーン内のいずれかのバックアップ仮想サーバが UP の場合、プライマリ仮想サーバにバインドされているすべてのサービスが DOWN であっても、プライマリ仮想サーバの有効な状態は UP になります。
次の図は、仮想サーバーが 1 つの状態から別の状態に移行する条件を示しています。
サービスは、次の状態を取ることができます。
-
UP: サービスにバインドされているすべてのモニタからのプローブが成功した場合。
-
DOWN:サービスに対する監視プローブが、設定された制限時間内に応答されない場合。
-
OUT OF SERVICE: サービスを管理上無効にした場合、またはサービスを正常にシャットダウンし、サービスに対するアクティブなトランザクションがない場合
-
GOING OUT OF SERVICE(TROFS):遅れてサービスを管理上無効にするか、サービスを正常にシャットダウンし、サービスへのアクティブなトランザクションがある場合。詳細については、「
サービスのグレースフルシャットダウン」を参照してください。
-
サービス外に出るときに停止 (TROFS_DOWN) サービスがアウトオブサービス状態にある間、モニタリングプローブが失敗します。
UP から OFS への移行プロセス中のサービスは、サービス終了状態です。ダウンから OFS に移行するサービスは、DOWN WHEN GOING OUT OF SERVICE状態になります。たとえば、サービスが DOWN で、遅延を伴って無効にした場合、サービスは DOWN WHEN GOING OUT OF SERVICE状態に移行し、その後 OUT OF SERVICE状態に移行します。サービスが UP で、遅延を伴って無効化すると、サービスはGOING OUT OF SERVICEに移行します。この間、サーバに対するモニタリングプローブが失敗すると、サービスはDOWN WHEN GOING OUT OF SERVICEに移行し、遅延時間が経過すると OFS 状態になります。
バックアップ仮想サーバーへのスピルオーバーを構成するには、"healthThreshold" パラメーターを 0 以外の正の値に設定します。次に、プライマリ仮想サーバにバインドされている単一のサービスがDOWN WHEN GOING OUT OF SERVICE状態に移行し、ヘルスのしきい値に達していない場合、プライマリ仮想サーバにはDOWNとマークされ、新しい接続がバックアップ仮想サーバに送信されます。
次の図は、サービスが 1 つの状態から別の状態に移行する条件を示しています。


