バックアップのパーシステンスを構成する

最終公開日 : Sep 25, 2026
プライマリ永続タイプが失敗したときに、ソース IP パーシステンスタイプを使用するように仮想サーバを設定できます。
次の表に、プライマリおよびセカンダリのバックアップパーシステンスタイプの組み合わせ、およびバックアップパーシステンスを使用する場合の条件を示します。
プライマリー・パーシスタンス バックアップ持続性 プライマリ・パーシスタンス検索が失敗すると...
クッキーインサート 接続元IP アプライアンスは、クライアントブラウザがリクエストで Cookie を返さない場合にのみ、ソース IP ベースのパーシステンスにフォールバックします。ただし、ブラウザが Cookie(パーシステンスクッキーである必要はありません)を返した場合、そのブラウザは Cookie をサポートしていると見なされるため、バックアップパーシスタンスはトリガーされません。
規則 接続元IP ルールで指定されたパラメータが受信リクエストに含まれていない場合、アプライアンスはソースIPベースの永続性を使用します。
注
  • プライマリ永続タイプが HTTP-Cookie ベースの永続性で、バックアップ永続性タイプが Source IP ベースの場合は、バックアップパーシステンスのタイムアウト値を設定できます。手順については、 アイドル状態のクライアント接続のタイムアウト値の設定を参照してください。
  • プライマリパーシステンスがルールベースの場合はバックアップパーシステンスのタイムアウト値を設定できません。この場合、セカンダリパーシステンスのタイムアウト値はプライマリパーシステンスのタイムアウト値と同じである必要があります。したがって、プライマリとセカンダリの有効期限は同時に切れます。

コマンドラインインターフェイスを使用して仮想サーバーのバックアップ永続性を設定するには

コマンドプロンプトで入力します。
set lb vserver <name> -persistenceType <PersistenceType> -persistenceBackup <BackupPersistenceType>
例:
set lb vserver Vserver-LB-1 -persistenceType CookieInsert -persistenceBackup SourceIP

set lb vserver Vserver-LB-1 -persistenceType sslsession -persistenceBackup SourceIP

set lb vserver Vserver-LB-1 –persistenceType RULE –rule http.req.header("User-Agent").value(0).contains("MyBrowser") –persistenceBackup SOURCEIP

set lb vserver Vserver-LB-1 -persistenceType sslsession -persistenceBackup SourceIP

構成ユーティリティを使用して仮想サーバーのバックアップ永続性を設定するには

  1. > > に移動し、仮想サーバーを開きます。
  2. **で、 を選択し、バックアップパーシステンスのタイプを指定します。
注:プライマリパーシスタンスは COOKIEINSERT、RULE、または SSLSESSION に設定する必要があります。