ドメインネームシステムがGSLBをサポートする方法
委任
sales.citrix.com、 education.citrix.com、support.citrix.comというサブドメインを作成できます。対応する部門は、サブドメインに対して権限のある独自のネームサーバーセットを保持し、ホスト名とアドレスマッピングの独自のセットを維持できます。すべてのCitrix アドレスレコードを管理する責任は、単一の部門ではありません。各部門は、アドレスを変更したり、トポロジを変更したり、上位レベルのドメインや組織でより多くの作業を課すことはありません。
階層トポロジの利点
-
スケーラビリティ
-
キャッシュ機能を各レベルでネームサーバーに追加する。DNS 要求は、特定のドメインに対して権限がないがクエリへの応答を提供できるホストによって処理され、輻輳と応答時間が短縮されます。
-
キャッシングは、サーバー障害に対する冗長性と回復力ももたらします。1 つのネームサーバーに障害が発生しても、同じレコードの最近キャッシュされたコピーを持つ他のサーバーからレコードを提供できる可能性があります。
リゾルバ
-
ネームサーバを照会する。
-
レスポンスの解釈(リソースレコードまたはエラーなど)。
-
情報を要求したプログラムに情報を返します。
ネームサーバー
citrix.com、サブドメイン内の別のネームサーバーにゾーンが委任されている場合、sales.citrix.comは別のゾーンです。この場合、プライマリCitrix ゾーンには citrix.com、 it.citrix.com、およびsupport.citrix.comを含めることができます 。sales.citrix.comが委任されるため、 citrix.comネームサーバが権限を持つゾーンの一部ではありません。次の図は、2 つのゾーンを示しています。
ns1.citrix.comにはsales.citrix.com サブドメインに関する情報は含まれていません。代わりに、 ns1.sales.citrix.com サブドメインに対して権限のあるネームサーバーへのポインタが含まれます。
ルートネームサーバーとクエリ解決
再帰クエリと非再帰クエリ
-
再帰クエリ:リゾルバとローカルに設定されたネームサーバー間のクエリは再帰的です。つまり、ネームサーバーはクエリを受信し、クエリが完全に応答されるか、エラーが返されるまでリゾルバに応答しません。ネームサーバがクエリへの参照を受信すると、ネームサーバが最終的に返された回答(IP アドレス)を受け取るまで、ネームサーバは参照に従います。
-
非再帰クエリ:ローカルで構成されたネームサーバーが、後続の権限のあるドメインレベルのネームサーバーに対して行うクエリは、非再帰 (または反復) です。各リクエストは、下位レベルの権限のあるサーバーへの参照、またはクエリに対する応答のいずれかで即座に応答されます(クエリされたネームサーバーがそのデータファイルまたはそのキャッシュに回答が含まれている場合)。
キャッシュ
リソースレコードタイプ
| リソースレコードタイプ | 説明 | RFC |
|---|---|---|
| A | ホストアドレス | RFC 1035 |
| NS | 権威あるネームサーバー | RFC 1035 |
| MD | メールの送信先 (廃止-MX を使用) | RFC 1035 |
| MF | メールフォワーダー (廃止-MX を使用) | RFC 1035 |
| CNAME | エイリアスの正規名 | RFC 1035 |
| SOA | 権限ゾーンの開始をマークします。 | RFC 1035 |
| WKS | よく知られているサービスの説明 | RFC 1035 |
| PTR | ドメイン名ポインタ | RFC 1035 |
| ヒント | ホスト情報 | RFC 1035 |
| MINFO | メールボックスまたはメールリストの情報 | RFC 1035 |
| MX | メール交換 | RFC 1035 |
| TXT | テキスト文字列 | RFC 1035 |
| AAAA | IP6 アドレス | RFC 3596 |
| SRV | サーバー選択 | RFC 2782] |
GSLB がDNSをサポートする方法
www.citrix.comにGSLBを使用する場合は、次のバインドSOAファイルを使用して、リクエストをwww.citrix.comからネームサーバーに委任できます。Netscaler1とNetscaler2。
###########################################################################
@ IN SOA citrix.com. hostmaster.citrix.com. (
1 ; serial
3h ; refresh
1h ; retry
1w ; expire
1h ) ; negative caching TTL
IN NS ns1
IN NS ns2
IN MX 10 mail
ns1 IN A 10.10.10.10
ns2 IN A 10.10.10.20
mail IN A 10.20.20.50
### Old Configuration if www was not delegated to a GSLB name server
www IN A 10.20.20.50
### Updated Configuration
Netscaler1 IN A xxx.xxx.xxx.xxx
Netscaler2 IN A yyy.yyy.yyy.yyy
www IN NS Netscaler1.citrix.com.
www IN NS Netscaler2.citrix.com.
###
IN MX 20 mail2
mail2 IN A 10.50.50.20
###########################################################################
-
現在の接続数が最も少ないサイト
-
ラウンドトリップ時間 (RTT) に基づいてリクエストを送信した LDNS サーバーに最も近いサイト。
メトリック交換プロトコル
-
サイトメトリック交換: これはポーリング交換モデルです。たとえば、site1 に site2 サービスの構成がある場合、第 2 サイト1 は site2 に GSLB サービスのステータスを要求します。Site2 は、状態およびその他のロードの詳細で応答します。
-
ネットワークメトリック交換: これは、動的近接負荷分散アルゴリズムで使用される LDNS RTT 情報交換です。これはプッシュ交換モデルです。5 秒ごとに、各サイトはそのデータを他の参加サイトにプッシュします。
-
永続性交換: これは SOURCEIP 永続性交換用です。これはプッシュ交換モデルでもあります。5 秒ごとに、各サイトはそのデータを他の参加サイトにプッシュします。