Comment le système de noms de domaine prend en charge GSLB
Délégation
sales.citrix.com``education.citrix.com, et support.citrix.com. Les services correspondants peuvent conserver leur propre ensemble de serveurs de noms qui font autorité pour leur sous-domaine, puis conserver leur propre ensemble de noms d'hôte pour les mappages d'adresses. Aucun service n'est responsable de la gestion de tous les enregistrements d'adresses Citrix. Chaque département peut modifier les adresses et modifier les topologies, sans imposer davantage de travail au domaine ou à l'organisation de niveau supérieur.
Avantages de la topologie hiérarchique
-
Scalabilité
-
Ajout d'une fonctionnalité de mise en cache dans les serveurs de noms à chaque niveau, où une requête DNS est gérée par un hôte qui ne fait pas autorité pour un domaine particulier, mais qui peut contribuer à la réponse à la requête et réduire la congestion et le temps de réponse.
-
La mise en cache crée également une redondance et une résilience face aux défaillances du serveur. Si un serveur de noms échoue, il est toujours possible que des enregistrements soient diffusés à partir d'autres serveurs disposant de copies mises en cache récentes des mêmes enregistrements.
Résolveurs
-
Interrogation d'un serveur de noms.
-
Interprétation des réponses (qui peuvent être des enregistrements de ressources ou une erreur).
-
Renvoyer l'information aux programmes qui en ont fait la demande.
Serveurs de noms
citrix.com, alors qu'il s' sales.citrix.com agit d'une zone distincte si cette zone est déléguée à un autre serveur de noms au sein du sous-domaine. Dans ce cas, la zone Citrix principale peut inclure citrix.com``it.citrix.com, et support.citrix.com. Étant donné que le sales.citrix.com est délégué, il ne fait pas partie de la zone sur laquelle le serveur de citrix.com noms fait autorité. Le diagramme suivant montre les deux zones.
ns1.citrix.com ne contient pas d'informations sur le sales.citrix.com sous-domaine. Il contient plutôt des pointeurs vers les serveurs de noms qui font autorité pour le ns1.sales.citrix.com sous-domaine.
Serveurs de noms racine et résolution des requêtes
Requêtes récursives et non récursives
-
Requête récursive : La requête entre le résolveur et le serveur de noms configuré localement est récursive. Cela signifie que le serveur de noms reçoit la requête et ne répond pas au résolveur tant que la requête n'a pas reçu une réponse complète ou qu'une erreur n'a pas été renvoyée. Si le serveur de noms reçoit une référence vers la requête, le serveur de noms suit la référence jusqu'à ce que le serveur de noms reçoive enfin la réponse (adresse IP) renvoyée.
-
Requête non récursive : La requête que le serveur de noms configuré localement effectue sur le serveur de noms de domaine faisant autorité ultérieur est non récursive (ou itérative). Chaque demande est immédiatement répondue par un renvoi vers un serveur faisant autorité de niveau inférieur ou la réponse à la requête, si le serveur de noms interrogé contient la réponse dans ses fichiers de données ou dans son cache.
Mise en cache
Types d'enregistrements de ressources
| Type d'enregistrement de ressource | Description | RFC |
|---|---|---|
| A | Une adresse d'hôte | RFC 1035 |
| NS | Un serveur de noms faisant autorité | RFC 1035 |
| MD | Une destination de messagerie (obsolète - utiliser MX) | RFC 1035 |
| MF | Un redirecteur de courrier (obsolète - utiliser MX) | RFC 1035 |
| CNAME | Le nom canonique d'un alias | RFC 1035 |
| SOA | Marque le début d'une zone d'autorité | RFC 1035 |
| WKS | Une description de service bien connue | RFC 1035 |
| PTR | Un pointeur de nom de domaine | RFC 1035 |
| HINFO | Informations sur l'hôte | RFC 1035 |
| MINFO | Informations sur la boîte aux lettres ou la liste de diffusion | RFC 1035 |
| MX | Échange de courrier | RFC 1035 |
| TXT | chaînes de texte | RFC 1035 |
| AAAA | Adresse IP6 | RFC 3596 |
| SRV | Sélection de serveurs | RFC 2782] |
Comment GSLB prend en charge le DNS
www.citrix.com, le fichier SOA Bind suivant peut être utilisé pour déléguer des demandes www.citrix.com à des serveurs de noms : Netscaler1 et Netscaler2.
###########################################################################
@ IN SOA citrix.com. hostmaster.citrix.com. (
1 ; serial
3h ; refresh
1h ; retry
1w ; expire
1h ) ; negative caching TTL
IN NS ns1
IN NS ns2
IN MX 10 mail
ns1 IN A 10.10.10.10
ns2 IN A 10.10.10.20
mail IN A 10.20.20.50
### Old Configuration if www was not delegated to a GSLB name server
www IN A 10.20.20.50
### Updated Configuration
Netscaler1 IN A xxx.xxx.xxx.xxx
Netscaler2 IN A yyy.yyy.yyy.yyy
www IN NS Netscaler1.citrix.com.
www IN NS Netscaler2.citrix.com.
###
IN MX 20 mail2
mail2 IN A 10.50.50.20
###########################################################################
-
Site avec le moins de connexions actuelles
-
Site le plus proche du serveur LDNS, qui a envoyé la demande en fonction des temps aller-retour (RTT).
Protocole d'échange de mesures
-
Échange de mesures de site : Il s'agit d'un modèle d'échange d'interrogation. Par exemple, si site1 dispose d'une configuration pour les services site2, un site1 demande à site2 l'état des services GSLB chaque seconde. Site2 répond avec l'état et d'autres détails de chargement.
-
Échange de mesures réseau : Il s'agit de l'échange d'informations LDNS RTT, utilisé dans l'algorithme d'équilibrage de charge de proximité dynamique. Il s'agit d'un modèle d'échange push. Toutes les cinq secondes, chaque site transmet ses données vers d'autres sites participants.
-
Échange de persistance : Il s'agit de l'échange de persistance SOURCEIP. Il s'agit également d'un modèle d'échange push. Toutes les cinq secondes, chaque site transmet ses données vers d'autres sites participants.