Telco利用者管理
-
加入者ポリシーの適用と管理。
-
完全な IPv6 アドレスではなく IPv6 プレフィックスだけを使用して加入者を一意に識別するようにアプライアンスを設定します。
-
ポリシーを使用して、動的サブスクライバとスタティックサブスクライバの両方の TCP トラフィックを最適化します。これらのポリシーは、さまざまな TCP プロファイルをさまざまなタイプのユーザーに関連付けます。
-
NetScalerアプライアンス上のアイドルセッションを管理します。
-
ログサーバーへのロギングを有効にします。
-
削除されたサブスクライバセッションの LSN セッションを削除します。
サブスクライバセッションストアモジュールへのメモリ割り当て
例
show extendedmemoryparam
Extended Memory Global Configuration. This memory is utilized by LSN and Subscriber Session Store Modules:
Active Memory Usage: 0 MBytes
Configured Memory Limit: 0 MBytes
Minimum Memory Required: 2058 MBytes
Maximum Memory Usage Limit: 2606 MBytes
Done
set extendedmemoryparam -memLimit 2558
Done
show extendedmemoryparam
Extended Memory Global Configuration. This memory is utilized by LSN and Subscriber Session Store Modules:
Active Memory Usage: 2558 MBytes
Configured Memory Limit: 2558 MBytes
Minimum Memory Required: 2058 MBytes
Maximum Memory Usage Limit: 2606 MBytes
Done
ダイナミックサブスクライバー用のインターフェースの設定
-
NetScaler リリース12.0ビルド57.19以降、クラスタ展開ではGxインターフェイスがサポートされます。詳細については、 クラスタトポロジの Gx インターフェイスを参照してください。
-
HA セットアップでは、サブスクライバセッションはセカンダリノードで継続的に同期されます。フェールオーバーが発生しても、サブスクライバ情報はセカンダリノードで引き続き使用できます。
Gx インターフェース
Gx インターフェイスを設定するには、次のタスクを実行します
add service pcrf-svc1 203.0.113.1 DIAMETER 3868
add service pcrf-svc2 203.0.113.2 DIAMETER 3868
add lb vserver vdiam DIAMETER 0.0.0.0 0 -persistenceType DIAMETER -persistAVPno 263
bind lb vserver vdiam pcrf-svc1
bind lb vserver vdiam pcrf-svc2
set ns diameter –identity netscaler.com –realm com
set subscriber gxInterface -vServer vdiam -pcrfRealm pcrf.com
set subscriber param -interfaceType GxOnly
show subscriber gxinterface
例
show subscriber gxinterface
Gx Interface parameters:
PCRF Vserver: vdiam (DOWN)
Gx Client Identity...: netscaler1.com
Gx Client Realm ..........: com
PCRF Realm: epc.mnc030.mcc234.3gppnetwork.org
Hold Packets On Subscriber Absence: YES
CCR Request Timeout: 4 Seconds
CCR Request Retry Attempts: 1
Gx HealthCheck enabled: NO
Gx HealthCheck TTL : 30 Seconds
CER Request Timeout: 10 Seconds
RevalidationTimeout: 30 Seconds
NegativeTTL: 60 Seconds
NegativeTTL Limited Success: NO
Purge SDB on Gx Failure: YES
ServicePath AVP code: 262099 ServicePath AVP VendorID: 3845
PCRF Connection State: PCRF is not ready
Done
引数
vServer
サービス
pcrfRealm
holdOnSubscriberAbsence
requestTimeout
requestRetryAttempts
healthCheck
healthCheckTTL
cerRequestTimeout
revalidationTimeout
negativeTTL
negativeTTLLimitedSuccess
purgeSDBonGxFailure
servicePathAVP
servicePathVendorid
GUI を使用して Gx インターフェイスを設定するには
確立された Gx 接続での転送障害を検出
-
DWA を受信すると、ピアのアベイラビリティが確認され、ウォッチドッグタイマーがリセットされます。
-
DWA が受信されず、ウォッチドッグタイマーが 2 回連続して期限切れになった場合、セッションはダウンしていてピアが使用できないと見なされます。アプライアンスはセッションを終了し、Gx ピアとの新しいセッションを確立しようとします。
CLI を使用して確立された Gx 接続での転送障害を検出するには
set subscriber gxInterface [-vServer <string>] [-service <string>] [-healthCheck ( YES | NO )] [-healthCheckTTL<positive_integer>][-cerRequestTimeout <positive_integer>] [-purgeSDBonGxFailure ( YES | NO )]
set subscriber gxInterface set subscriber gxInterface -vServer vdiam -healthCheck YES -healthCheckTTL 31 -cerRequestTimeout 15 purgeSDBonGxFailure YES
GUI を使用して確立された Gx 接続での転送障害を検出するには
クラスタ・トポロジーの Gx インターフェース
-
CCR-I 要求を PCRF サーバに送信して、加入者情報を取得します。
-
PCRF サーバは CCR-A で応答します。
-
次に、NetScalerノードは受信したサブスクライバー情報をサブスクライバーストアに保存し、ルールをクライアントトラフィックに適用します。
GUI を使用して直径パラメータを設定するには
CLI を使用して直径パラメータを設定するには
set ns diameter [-identity <string>] [-ownerNode <positive_integer>]
引数
ユーザー情報
オーナーノード
show diameter -ownerNode <0-31>
クラスタ展開用の Gx インターフェイスを設定するには
add service pcrf-svc1 203.0.113.1 DIAMETER 3868
add service pcrf-svc2 203.0.113.2 DIAMETER 3868
add lb vserver vdiam DIAMETER 0.0.0.0 0 -persistenceType DIAMETER -persistAVPno 263
bind lb vserver vdiam pcrf-svc1
bind lb vserver vdiam pcrf-svc2
set ns diameter -identity node0.netscaler.com -realm netscaler.com -ownerNode 0
set ns diameter -identity node1.netscaler.com -realm netscaler.com -ownerNode 1
set subscriber gxInterface -vServer vdiam -pcrfRealm pcrf.com
Set the subscriber interface type to GxOnly.
set subscriber param -interfaceType GxOnly
show subscriber gxinterface
RADIUS インターフェイス
add service srad1 192.0.0.206 RADIUSLISTENER 1813
set subscriber radiusInterface -listeningService srad1
set subscriber param -interfaceType RadiusOnly
add radius client 192.0.2.0/24 -radkey client123
show subscriber radiusInterface
add service pcrf-svc1 203.0.113.1 DIAMETER 3868
add service pcrf-svc2 203.0.113.2 DIAMETER 3868
引数
ListeningService
svrState
GUI を使用して RADIUS 専用インターフェイスを設定するには
RADIUS および Gx インターフェイス
set subscriber param -interfaceType RadiusandGx
add service pcrf-svc 203.0.113.1 DIAMETER 3868
add lb vserver vdiam DIAMETER 0.0.0.0 0 -persistenceType DIAMETER -persistAVPno 263
bind lb vserver vdiam pcrf-svc
set subscriber gxInterface -vServer vdiam -pcrfRealm testrealm1.net -holdOnSubscriberAbsence YES -revalidationTimeout 60 -negativeTTL 120
add service srad1 192.0.0.206 RADIUSLISTENER 1813 set subscriber radiusInterface -listeningService srad1
GUI を使用して RADIUSandGX インターフェイスを設定するには
スタティックサブスクライバーの設定
add subscriber profile 203.0.113.6 -subscriberRules policy1 policy2 -subscriptionIdType E164 -subscriptionIdvalue 98767543211
add subscriber profile 2002::a66:e8d3/64 -subscriberRules policy1 policy3 -subscriptionIdtype E164 -subscriptionIdvalue 98767543212
add subscriber profile 203.0.24.2 10 -subscriberRules policy2 policy3 -subscriptionIdtype E164 -subscriptionIdvalue 98767543213
> show subscriber profile
1) Subscriber IP: 203.0.24.2 VLAN:10
Profile Attributes:
Active Rules: policy2, policy3
Subscriber Id Type: E164
Subscriber Id Value: 98767543213
2) Subscriber IP: 2002::/64
Profile Attributes:
Active Rules: policy1, policy3
Subscriber Id Type: E164
Subscriber Id Value: 98767543212
3) Subscriber IP: 203.0.113.6
Profile Attributes:
Active Rules: policy1, policy2
Subscriber Id Type: E164
Subscriber Id Value: 98767543211
Done
デフォルト加入者プロファイル
> add subscriber profile * -subscriberRules policy1
サブスクライバーセッションの表示とクリア
> show subscriber sessions
1) Subscriber IP: 2002::/64
Session Attributes:
Active Rules: policy1, policy3
Subscriber Id Type: E164
Subscriber Id Value: 98767543212
2) Subscriber IP: *
Session Attributes:
Active Rules: policy1
3) Subscriber IP: 203.0.24.2 VLAN:10
Session Attributes:
Active Rules: policy2, policy3
Subscriber Id Type: E164
Subscriber Id Value: 98767543213
4) Subscriber IP: 203.0.113.6
Session Attributes:
Active Rules: policy1, policy2
Subscriber Id Type: E164
Subscriber Id Value: 98767543211
5) Subscriber IP: 192.168.0.11
Session Attributes:
Idle TTL remaining: 361 Seconds
Active Rules: policy1
Subscriber Id Type: E164
Subscriber Id Value: 1234567811
Service Path: policy1
AVP(44): 34 44 32 42 42 38 41 43 2D 30 30 30 30 30 30 31 31
AVP(257): 00 01 C0 A8 0A 02
PCRF-Host: host.pcrf.com
AVP(280): 74 65 73 74 2E 63 6F 6D
Done
clear subscriber sessions <ip>
加入者ポリシーの適用および管理システム
add responder action error_msg respondwith '"HTTP/1.1 403 OKrnrn" + " You are not authorized to access Internet"'
add responder policy no_internet_access "SUBSCRIBER.RULE_ACTIVE("pol1")" error_msg
> add rewrite action AddHDR-act insert_http_header X-Nokia-MSISDN "SUBSCRIBER.AVP(45).VALUE"
> add rewrite policy AddHDR-pol "HTTP.REQ.HOSTNAME.APPEND(HTTP.REQ.URL).EQUALS_ANY("patset-test")" AddHDR-act
> add cache policy nocachepol -rule "SUBSCRIBER.RULE_ACTIVE("cache_disable")" - action NOCACHE
> add cache policy cachepol -rule "SUBSCRIBER.RULE_ACTIVE("cache_enable")" - action CACHE -storeInGroup cg1
IPv6 プレフィクスベースのサブスクライバセッション
コマンドラインを使用して IPv6 プレフィックスを構成するには
set subscriber param [-ipv6PrefixLookupList <positive_integer> ...]
set subscriber param -ipv6PrefixLookupList 64
set subscriber param -ipv6PrefixLookupList 64 72 96
構成ユーティリティを使用して IPv6 プレフィックスを構成するには
IP アドレスと VLAN ID キーの検索方法
-
IPv4 サブスクライバの Gx クエリに発信元の VLAN ID を含めます。
-
すべての Gx 応答に Gx VLAN AVP を含めます。ただし、VLAN ID が一致しない場合、アプライアンスは応答を無視します。
-
インターフェイスタイプ RADIUSandGX と RADIUSOnly をキータイプ IPAND VLAN と一緒に設定することはできません。
-
トラフィックがIPv6アドレスからのものである場合、NetScalerアプライアンスはIPルックアップ方式を使用します。
CLI を使用して IP または IPANDVLAN をキールックアップ方式として設定するには
set subscriber param [-keytype ( IP | IPANDVLAN )] [-interfaceType <interfaceType>]
set subscriber param -keytype IPANDVLAN -interfaceType GxOnly
set subscriber param -keytype IP -interfaceType GxOnly
VLAN パラメータ
add subscriber profile <ip>@ [-vlan]
set subscriber profile <ip>@ [-vlan] [-subscriptionIdType <subscriptionIdType>]
show subscriber profile [<ip>@] [-vlan]
rm subscriber profile <ip>@ [-vlan <positive_integer>]
引数
IP
vlan
add subscriber profile 192.0.2.23 10
set subscriber profile 192.0.2.23 10 -subscriptionIdtype E164
show subscriber profile 192.0.2.23 10
rm subscriber profile 192.0.2.23 10
GUI を使用してキールックアップ方式として IP または IPANDVLAN を設定するには
Telco ネットワーク内の加入者セッションのアイドルセッション管理
コマンドラインを使用してアイドルセッションのタイムアウトと関連するアクションを設定するには
set subscriber param [-idleTTL <positive_integer>] [-idleAction <idleAction>]
set subscriber param -idleTTL 3600 -idleAction ccrTerminate
set subscriber param -idleTTL 3600 -idleAction ccrUpdate
set subscriber param -idleTTL 3600 -idleAction delete
設定ユーティリティを使用してアイドルセッションのタイムアウトと関連するアクションを設定するには
サブスクライバーセッションイベントロギング
-
セッションイベント (インストール、更新、削除、エラー)
-
Gx メッセージタイプ (CCR-I、CCR-U、CCR-T、RAR)
-
Radius メッセージタイプ (開始、停止)
-
サブスクライバー IP
-
サブスクライバ ID タイプ (MSISDN (E164)、IMSI)
-
サブスクライバー ID の値
> add syslogAction sysact1 192.0.2.0 -loglevel EMERGENCY ALERT CRITICAL ERROR WARNING NOTICE INFORMATIONAL -subscriberlog enabled
-
次のログエントリは、RadiusAndGX セッションの作成、セッション更新、およびセッション削除の例です。09/30/2015:16:29:18 GMT Informational 0-PPE-0 : default SUBSCRIBER SESSION_EVENT 147 0 : Session Install, GX MsgType: CCR-I, RADIUS MsgType: Start, IP: 100.10.1.1, ID: E164 - 3000000000109/30/2015:16:30:18 GMT Informational 0-PPE-0 : default SUBSCRIBER SESSION_EVENT 148 0 : Session Update, GX MsgType: CCR-U, IP: 100.10.1.1, ID: E164 - 3000000000109/30/2015:17:27:56 GMT Informational 0-PPE-0 : default SUBSCRIBER SESSION_EVENT 185 0 : Session Delete, GX MsgType: CCR-T, RADIUS MsgType: Stop, IP: 100.10.1.1, ID: E164 - 30000000001
-
次のログエントリは、PCRF サーバでサブスクライバが見つからない場合や、アプライアンスが PCRF サーバに接続できない場合などのエラーメッセージの例です。09/30/2015:16:44:15 GMT Error 0-PPE-0 : default SUBSCRIBER SESSION_FAILURE 169 0 : Failure Reason: PCRF failure response, GX MsgType: CCR-I, IP: 100.10.1.1Sep 30 13:03:01 09/30/2015:16:49:08 GMT 0-PPE-0 : default SUBSCRIBER SESSION_FAILURE 176 0 : Failure Reason: Unable to connect to PCRF, GX MsgType: CCR-I, RADIUS MsgType: Start, IP: 100.10.1.1, ID: E164 - 30000000001#000#000#000#000#000#000#000#000#000#000#000#000#000#000#000#000
サブスクライバ対応 LSN セッション終了
CLI を使用してサブスクライバ対応 LSN セッション終了を設定するには
> set lsn parameter -subscrSessionRemoval ENABLED
Done
> sh lsn parameter
LSN Global Configuration:
Active Memory Usage: 0 MBytes
Configured Memory Limit: 0 MBytes
Maximum Memory Usage Limit: 912 MBytes
Session synchronization: ENABLED
Subscriber aware session removal: ENABLED
GUI を使用してサブスクライバ対応 LSN セッション終了を設定するには
トラブルシューティング
-
show subscriber gxinterface このコマンドの出力には、次のエラーメッセージが含まれる場合があります (ここでは、推奨される応答と共に示しています)。
-
Gx インターフェイスが設定されていません-set subscriber param コマンドを使用して正しいインターフェイスタイプを設定してください。
-
PCRF が設定されていません-GXInterface で Diameter 仮想サーバーまたはサービスを設定してください。set subscriber gx interface コマンドを使用して、このインターフェイスに Diameter 仮想サーバーまたはサービスを割り当ててください。
-
PCRF が準備完了ではありません。詳細については、対応する vserver/service を確認してください。show LB vserver または show service コマンドを使用して、サービスの状態を確認してください。
-
NetScalerはPCRFからのCEAを待っています。PCRFとNetScaler間の機能ネゴシエーションが失敗している可能性があります。これは断続的な状態である可能性があります。それでも解決しない場合は、PCRF サーバーの DIAMETER 設定を確認してください。
-
メモリはサブスクライバセッションを保存するように設定されていません。'set extendedmemoryparam-memlimit <>'を使用してください。-set extendedmemoryparam コマンドを使用して拡張メモリを設定してください。
-
-
show subscriber radiusinterface このコマンドの出力が「未設定」の場合は、set subscriber radiusinterface コマンドを使用して RADIUSListener サービスを指定してください。