サービスの監視なしオプション
-
監視なしオプションを有効にしたサービスが停止しても、アプライアンスは引き続きサービスを稼働中として表示し、トラフィックをサービスに転送し続けます。サービスへの永続的な接続は状況を悪化させる可能性があります。その場合、または UP と表示されている多くのサービスが実際にDOWNの場合、システムに障害が発生する可能性があります。このような状況を回避するには、サービスを監視する外部メカニズムがサービスをDOWNと報告するときに、NetScaler ADC構成からサービスを削除します。
-
サービスで no-monitor オプションを構成する場合は、ダイレクトサーバーリターン (DSR) モードでロードバランシングを構成できません。既存のサービスでは、no-monitor オプションを設定すると、そのサービスの DSR モードを設定できません。
CLI を使用して新しいサービスの監視なしオプションを設定するには
add service <serviceName> <IP | serverName> <serviceType> <port> -healthMonitor (YES|NO)
add service nomonsrvc 10.102.21.21 http 80 -healthMonitor no
Done
show service nomonsrvc
nomonsrvc (10.102.21.21:80) - HTTP
State: UP
Last state change was at Mon Nov 15 22:41:29 2010
Time since last state change: 0 days, 00:00:00.970
Server Name: 10.102.21.21
Server ID : 0 Monitor Threshold : 0
...
Access Down Service: NO
...
Down state flush: ENABLED
Health monitoring: OFF
1 bound monitor:
1) Monitor Name: tcp-default
State: UNKNOWN Weight: 1
Probes: 3 Failed [Total: 3 Current: 3]
Last response: Probe skipped - Health monitoring is turned off.
Response Time: N/A
Done
CLI を使用して既存のサービスの監視なしオプションを設定するには
set service <name> -healthMonitor (YES|NO)
By default, the state of a service and the state of the corresponding monitor are UP.
>show service LB-SVC1
LB-SVC1 (10.102.29.5:80) - HTTP
State: UP
1) Monitor Name: http-ecv
State: UP Weight: 1
Probes: 99992 Failed [Total: 0 Current: 0]
Last response: Success - Pattern found in response.
Response Time: 3.76 millisec
Done
When the no-monitor option is set on a service, the state of the monitor changes to UNKNOWN.
set service LB-SVC1 -healthMonitor NO
Done
show service LB-SVC1
LB-SVC1 (10.102.29.5:80) - HTTP
State: UP
Last state change was at Fri Dec 10 10:17:37 2010.
Time since last state change: 5 days, 18:55:48.710
Health monitoring: OFF
1) Monitor Name: http-ecv
State: UNKNOWN Weight: 1
Probes: 100028 Failed [Total: 0 Current: 0]
Last response: Probe skipped - Health monitoring is turned off.
Response Time: 0.0 millisec
Done
When the no-monitor option is removed, the earlier state of the monitor is resumed.
> set service LB-SVC1 -healthMonitor YES
Done
>show service LB-SVC1
LB-SVC1 (10.102.29.5:80) - HTTP
State: UP
Last state change was at Fri Dec 10 10:17:37 2010
Time since last state change: 5 days, 18:57:47.880
1) Monitor Name: http-ecv
State: UP Weight: 1
Probes: 100029 Failed [Total: 0 Current: 0]
Last response: Success - Pattern found in response.
Response Time: 5.690 millisec
Done
GUI を使用してサービスの監視なしオプションを設定するには
-
[Traffic Management] > [Load Balancing] > [Services] の順に移動します。
-
サービスを開き、ヘルスモニタリングをクリアします。