The no-monitor option for services
-
If a service for which you enabled the no-monitor option goes down, the appliance continues to show the service as UP and continues to forward traffic to the service. A persistent connection to the service can worsen the situation. In that case, or if many services shown as UP are actually DOWN, the system may fail. To avoid such a situation, when the external mechanism that monitors the services reports a service as DOWN, remove the service from the NetScaler configuration.
-
If you configure the no-monitor option on a service, you cannot configure load balancing in the Direct Server Return (DSR) mode. For an existing service, if you set the no-monitor option, you cannot configure the DSR mode for the service.
To set the no-monitor option for a new service by using the CLI
add service <serviceName> <IP | serverName> <serviceType> <port> -healthMonitor (YES|NO)
add service nomonsrvc 10.102.21.21 http 80 -healthMonitor no
Done
show service nomonsrvc
nomonsrvc (10.102.21.21:80) - HTTP
State: UP
Last state change was at Mon Nov 15 22:41:29 2010
Time since last state change: 0 days, 00:00:00.970
Server Name: 10.102.21.21
Server ID : 0 Monitor Threshold : 0
...
Access Down Service: NO
...
Down state flush: ENABLED
Health monitoring: OFF
1 bound monitor:
1) Monitor Name: tcp-default
State: UNKNOWN Weight: 1
Probes: 3 Failed [Total: 3 Current: 3]
Last response: Probe skipped - Health monitoring is turned off.
Response Time: N/A
Done
To set the no-monitor option for an existing service by using the CLI
set service <name> -healthMonitor (YES|NO)
By default, the state of a service and the state of the corresponding monitor are UP.
>show service LB-SVC1
LB-SVC1 (10.102.29.5:80) - HTTP
State: UP
1) Monitor Name: http-ecv
State: UP Weight: 1
Probes: 99992 Failed [Total: 0 Current: 0]
Last response: Success - Pattern found in response.
Response Time: 3.76 millisec
Done
When the no-monitor option is set on a service, the state of the monitor changes to UNKNOWN.
set service LB-SVC1 -healthMonitor NO
Done
show service LB-SVC1
LB-SVC1 (10.102.29.5:80) - HTTP
State: UP
Last state change was at Fri Dec 10 10:17:37 2010.
Time since last state change: 5 days, 18:55:48.710
Health monitoring: OFF
1) Monitor Name: http-ecv
State: UNKNOWN Weight: 1
Probes: 100028 Failed [Total: 0 Current: 0]
Last response: Probe skipped - Health monitoring is turned off.
Response Time: 0.0 millisec
Done
When the no-monitor option is removed, the earlier state of the monitor is resumed.
> set service LB-SVC1 -healthMonitor YES
Done
>show service LB-SVC1
LB-SVC1 (10.102.29.5:80) - HTTP
State: UP
Last state change was at Fri Dec 10 10:17:37 2010
Time since last state change: 5 days, 18:57:47.880
1) Monitor Name: http-ecv
State: UP Weight: 1
Probes: 100029 Failed [Total: 0 Current: 0]
Last response: Success - Pattern found in response.
Response Time: 5.690 millisec
Done
To set the no-monitor option for a service by using the GUI
-
Navigate to Traffic Management > Load Balancing > Services.
-
Open the service, and clear Health Monitoring.