You can configure a virtual server to use the source IP persistence type when the primary persistence type fails.
The following table describes the combinations of primary and secondary backup persistence types, and the conditions when the backup persistence is used.
| Primary persistence |
Backup persistence |
When the primary persistence lookup fails… |
| Cookie Insert |
Source IP |
The appliance falls back to source-IP based persistence only when the client browser does not return any cookie in the request. However, if the browser returns a cookie (not necessarily the persistence cookie) it is assumed that the browser supports cookies and hence backup persistence is not triggered. |
| Rule |
Source IP |
The appliance uses source-IP based persistence when the parameter specified in the rule is missing in the incoming request. |
-
-
You cannot set a timeout value for backup persistence when the primary persistence is rule based, because in that case the timeout value for secondary persistence must be the same as for the primary persistence. Therefore, the primary and secondary expire at the same time.