トラブルシューティング
-
NetScaler VPXアプライアンスの統計は、アプライアンスがセッション永続性の制限に達したことを示しています。その結果、パーシスタンスセッションは失敗します。セッション持続性の制限を増やすことはできますか?原因: NetScalerアプライアンスのシステム制限は、コアあたり250,000パーシステンスセッションです。解決策: この問題を解決するには、次のいずれかのタスクを実行できます。
-
永続性のタイムアウト値を減らす
-
アプライアンスのコア数を増やす
-
-
NetScalerアプライアンスでCookie Insertパーシステンスを構成すると、接続はしばらくの間正常に機能したが、その後切断され始めるという報告がユーザーから寄せられました。パーシスタンスを設定する際には、どのようなベストプラクティスに従うべきですか?原因:デフォルトでは、Cookie Insert パーシステンスのタイムアウト値は 120 秒です。解決策:アイドル時間を特定できないアプリケーションのパーシステンスを設定する場合は、Cookie Insert のパーシステンスタイムアウト値を 0 に設定します。この設定では、接続はタイムアウトしません。
-
NetScalerアプライアンスでHTTP仮想サーバーを構成した後、要求されたコンテンツに対してユーザーが常に同じサーバーに接続するようにする必要があるため、SourceIPパーシステンスを構成しました。現在、パーシスタンスのタイムアウト値を増やすとレイテンシーが発生します。パフォーマンスに影響を与えずにタイムアウト値を増やすにはどうすればよいですか?解決策:タイムアウト値を 0 に設定して Cookie Insert パーシステンスを使用することを検討してください。この設定では、アプライアンスがCookie の有効期限を指定しないため、長期間のパーシスタンスの設定が可能になります。
-
NetScalerアプライアンスでCookie Insertパーシステンスを構成すると、同じタイムゾーンのクライアントがコンテンツにアクセスしても期待どおりに機能します。ただし、別のタイムゾーンのクライアントが接続を試みると、接続はすぐにタイムアウトします。原因:同じタイムゾーンのクライアントが接続を行うと、時間ベースの Cookie Insert パーシスタンスは期待どおりに機能します。ただし、クライアントマシンとNetScaler ADCアプライアンスが異なるタイムゾーンにある場合、Cookieは無効です。たとえば、EST タイムゾーンのクライアントが午前 11:00 にクッキーをPSTタイムゾーンのNetScaler ADCアプライアンスに送信すると、アプライアンスは太平洋標準時午後2時にCookieを受信します。時間の差異の結果、クッキーは有効ではなく、接続がすぐにタイムアウトします。解決策:Cookie Insert パーシステンスのタイムアウト値を 0 に設定します。
-
NetScalerアプライアンスは、Oracle Weblogicサーバーなどのアプリケーションサーバーの負荷分散に使用されます。クライアントがこれらのサーバに常時接続できるようにするため、SourceIP パーシステンスが設定されています。コンピューターから接続すると、期待どおりに機能します。ただし、シンクライアントがターミナルサーバー経由で接続を試みた結果、アプライアンスは同じIPアドレス(ターミナルサーバーのIPアドレス)から複数のクライアントからの要求を受信します。したがって、すべてのシンクライアントからの接続は、同じアプリケーションサーバーに転送されます。クライアント IP アドレスに基づいて個々のシンクライアントからのリクエストに永続性を設定することはできますか?原因:NetScalerアプライアンスはターミナルサーバーから要求を受信しますが、要求の送信元IPアドレスは変わりません。その結果、アプライアンスはシンクライアントから受信したリクエストを区別できず、シンクライアントからのリクエストに応じたパーシステンスを提供できません。解決策:この問題を回避するには、シンクライアントごとに固有のパラメータ値に基づいてルール永続性を設定できます。
-
NetScalerアプライアンスは、Web Interfaceサーバーの負荷分散に使用されます。サーバーにアクセスすると、ユーザーは「State Error」エラーメッセージを受け取ります。さらに、Web Interface サーバーの 1 つがシャットダウンしたり使用できなくなったりすると、一部のユーザーにエラーメッセージが表示されます。原因:Web Interfaceサーバーへの永続性が欠如していると、ユーザーがサーバーに接続しようとしたときにエラーメッセージが表示されることがあります。解決策:Web Interfaceサーバーの負荷分散を行う場合は、NetScalerアプライアンスでCookie挿入パーシステンス方式を指定することをCitrixでは推奨しています。