Managing RAID disk allocation on the SDX platform
View drive properties and operations
Storage repository
-
Name: Name of the storage repository drive.
-
Is Drive Attached: Whether the storage repository is attached or not. If the drive is not attached, you can click Remove to delete.
-
Size: Size of the storage repository.
-
Utilized: Amount of storage-repository space in use.
Logical drives
| State | Description |
|---|---|
| Optimal | The logical drive operating condition is good. All configured drives are online. |
| Degraded | The logical drive operating condition is not optimal. One of the configured drives has failed or is offline. |
| Failed | The logical drive has failed. |
| Offline | The logical drive is not available to the RAID controller. |
| Active | The logical drive is fully active, disk I/O and/or resync can be happening. |
| Clean | The logical drive is active, but does not have any pending write operations. |
| Recovering | All data on the logical drive is being written from the running array to fill up a new disk with all the relevant data. |
| Resync | All data on the array is being synchronized from the running array. However, most, if not all, of the data is OK. |
Create a new logical drive
-
Navigate to Configuration > System > RAID, and select the Logical Drives tab.
-
Click Add.
-
In the Create Logical Disk dialog box, select two slots that contain operational physical drives, and then click Create.
Add a logical drive to the SDX Platform
-
On the back of the appliance, insert the two blank SSDs in slot numbers 5 and 6. You can add the SSDs in a running system.Note:Make sure that the SSDs are NetScaler® certified.
-
In the Management Service, navigate to Configuration > System > RAID and the Physical Drives tab. You can see the SSDs that you added.
-
Navigate to the Logical Drive tab and click Add.
-
In the Create Logical Disk page:
-
In the First Slot drop-down list, select 5.
-
In the Second Slot drop-down list, select 6.
-
Click Create.Note: In Management Service, the slot number begins with zero. So the slot numbering in Management Service differs from the slot numbering on the physical appliance.
-
The logical drive is created and is listed under the Logical Drive tab. Click the refresh icon to update the order of the logical drives.
-
Add a second logical drive on the SDX Platform
-
To add another logical drive, insert the SSDs in slot numbers 7 and 8.
-
In the Create Logical Disk page:
-
In the First Slot drop-down list, select 7.
-
In the Second Slot drop-down list, select 8.
-
Click Create
-
-
The logical drive is created and is listed under the Logical Drive tab. Click the refresh icon to update the order of the logical drives.
Physical drives
-
Slot: Physical slot associated with the physical drive.
-
State: Indicates if a physical drive is present on the appliance.
-
Present Physical drive is present on the appliance.
-
Size: Size of the physical drive.
-
Not Present It means that either the physical drive is absent on the appliance or it has been deactivated so that it can be removed.
-
Firmware State: State of the firmware. Possible Values:
-
Online, spun up: Physical drive is up and is controlled by RAID.
-
Unconfigured (good): Physical drive is in good condition and can be added as a part of the logical drive pair.
-
Unconfigured (bad): Physical drive is not in good condition and cannot be added as part of a logical drive.
-
-
Foreign State: Indicates if the disk is empty.
-
Logical Drive: Associated logical drive.
-
RAID State It defines the raid state of the physical drives.
-
active, sync: Physical drive in good condition in sync with pending writes.
-
clean, sync: Physical drive in good condition in sync with no pending writes.
-
spare, rebuilding: A new physical drive is being filled up with relevant data.
-
faulty: Physical drive in a faulty state.
-
-
Initialize: Initialize the disk. You can initialize the physical drive if it is not in good state and must be added as a part of the logical drive pair.
-
Rebuild: Initiate a rebuild of the drive. When a drive in a drive group fails, you can rebuild the drive by re-creating the data that was stored on the drive before it failed. The RAID controller re-creates the data stored on the other drives in the drive group.
-
Locate: Locate the drive on the appliance, indicated by causing the Drive Activity LED associated with the drive to blink.
-
Stop Locate: Stop locating the drive on the appliance.
-
Prepare to Remove: Deactivate the selected physical drive so that it can be removed.
-
Raid support
Replace a defective RAID-supported SSD drive with a blank SSD drive
-
Navigate to Configuration > System > RAID.
-
On the Physical Drives tab, select the defective drive that you want to replace.
-
Click Prepare to Remove to remove the drive.
-
Click Physical Drives. The state of the drive must now appear as Not Present.
-
Locate the SSD on the back panel of the appliance. Push the safety latch of the drive cover down while pulling out on the drive handle to disengage. Pull out the faulty drive.
-
Ensure that the new SSD is the same size as the old one. For example, if the old drive is 480 GB, the new one must be 480 GB.
-
Open the drive handle fully up, and insert the new Citrix-certified SSD into the slot as far as possible. To seat the drive, close the handle flush with the rear of the appliance so that the drive locks securely into the slot.When inserting the drive, orient the drive handle the same way as the installed drives.
-
Click the refresh icon for the list of physical drives. The state of the drive must appear as Present.
-
Select the drive first and then click the Rebuild option. Click OK when the Rebuild Physical Drive dialog box is displayed. After you replace one of the SSDs, the configuration on the other SSD in the mirrored SSD is copied to the replacement SSD.Note:A Force Clean check option is available in Rebuild Physical Drive dialog box to erase any existing RAID metadata on the drive. The drive is considered as a foreign drive if it came from another RAID setup or has old RAID metadata that must be erased.
-
Click the refresh icon to check the status of the rebuild process. When the rebuild process is complete, you can see Online, Spun Up status in the Firmware State column.
Replace a defective RAID logical Drive with two blank SSD Drives
-
In the Management Service NetScaler tab, select and delete each of the VPX instances residing on the failed VPX-SR.
-
Navigate to Configuration > System > RAID, and select the Logical Drives tab.
-
Select the failed logical drives and click Delete.
-
Replace the failed drives with new Citrix-certified SSD drives in the corresponding slot pair.
-
Select the logical drives, and click Create.
-
The logical drive is re-created and ready for use. The VPX instances that were deleted earlier can now be created or restored as required.