Vous pouvez configurer l'appliance NetScaler pour qu'elle fonctionne en tant que serveur ADNS, serveur proxy DNS, résolveur final et redirecteur. Vous pouvez ajouter des enregistrements de ressources DNS sur l'appliance NetScaler, notamment les enregistrements suivants :
-
Enregistrements de service (SRV)
-
Enregistrements IPv6 (AAAA)
-
Enregistrements d'adresse (A)
-
Enregistrements d'échange de courrier (MX)
-
Enregistrements de noms canoniques (CNAME)
-
Enregistrements Pointer (PTR)
-
Enregistrements de début d'autorité (SOA)
-
Enregistrements texte (TXT)
-
Enregistrements de pointeur d'autorité de nom (NAPTR)
-
Dossiers DNSKEY
-
Enregistrements d'autorisation de l'autorité de certification (CAA)
Vous pouvez également configurer NetScaler pour équilibrer la charge des serveurs de noms DNS externes.
L'appliance NetScaler peut être configurée en tant qu'autorité pour un domaine. Ajoutez des enregistrements SOA et NS valides pour le domaine.
Un serveur ADNS est un serveur DNS qui contient des informations complètes sur une zone.
Pour configurer l'appliance NetScaler en tant que serveur ADNS pour une zone, vous devez ajouter un service ADNS, puis configurer la zone. Pour ce faire, vous devez ajouter des enregistrements SOA et NS valides pour le domaine. Lorsqu'un client envoie une demande DNS, l'appliance NetScaler recherche le nom de domaine dans les enregistrements de ressources configurés. Vous pouvez configurer le service ADNS à utiliser avec la fonctionnalité NetScaler Global Server Load Balancing (GSLB).
Vous pouvez déléguer un sous-domaine en ajoutant des enregistrements NS pour le sous-domaine à la zone du domaine parent. Vous pouvez ensuite faire en sorte que NetScaler fasse autorité pour le sous-domaine en ajoutant un « enregistrement colle » pour chacun des serveurs de noms de sous-domaines. Si le GSLB est configuré, NetScaler prend une décision d'équilibrage de charge GSLB en fonction de sa configuration et répond avec l'adresse IP du serveur virtuel sélectionné. La figure suivante montre les entités d'une configuration GSLB ADNS et d'une configuration de proxy DNS.
Figure 1. Modèle d'entité proxy DNS
L'appliance NetScaler peut fonctionner comme un proxy DNS. La mise en cache des enregistrements DNS, qui constitue une fonction importante d'un proxy DNS, est activée par défaut sur l'appliance NetScaler. La mise en cache permet à l'appliance NetScaler de fournir des réponses rapides pour les traductions répétées. Créez un serveur virtuel DNS d'équilibrage de charge et des services DNS, puis liez ces services au serveur virtuel.
NetScaler propose deux options, la durée de vie minimale (TTL) et la TTL maximale pour configurer la durée de vie des données mises en cache. Les données mises en cache expirent conformément à vos paramètres pour ces deux options. NetScaler vérifie le TTL de l'enregistrement DNS provenant du serveur. Si la durée de vie est inférieure à la durée de vie minimale configurée, elle est remplacée par la durée de vie minimale configurée. Si la durée de vie est supérieure à la durée de vie maximale configurée, elle est remplacée par la durée de vie maximale configurée.
NetScaler permet également la mise en cache des réponses négatives pour un domaine. Une réponse négative indique que les informations concernant un domaine demandé n'existent pas ou que le serveur ne peut pas fournir de réponse à la requête. Le stockage de ces informations est appelé mise en cache négative. La mise en cache négative permet d'accélérer les réponses aux requêtes sur un domaine et peut éventuellement fournir le type d'enregistrement.
Une réponse négative peut être l'une des suivantes :
-
Message d'erreur NXDOMAIN - Si une réponse négative est présente dans le cache local, NetScaler renvoie un message d'erreur (NXDOMAIN). Si la réponse ne se trouve pas dans le cache local, la requête est transmise au serveur, qui renvoie une erreur NXDOMAIN à NetScaler. NetScaler met la réponse en cache localement, puis renvoie le message d'erreur au client.
-
Message d'erreur NODATA : NetScaler envoie un message d'erreur NODATA si le nom de domaine de la requête est valide mais que les enregistrements du type indiqué ne sont pas disponibles.
NetScaler prend en charge la résolution récursive des requêtes DNS. En résolution récursive, le résolveur (client DNS) envoie une requête récursive à un serveur de noms pour un nom de domaine. Si le serveur de noms interrogé fait autorité pour le domaine, il répond avec le nom de domaine demandé. Sinon, NetScaler interroge les serveurs de noms de manière récursive jusqu'à ce que le nom de domaine demandé soit trouvé.
Avant de pouvoir appliquer l'option de requête récursive, vous devez d'abord l'activer. Vous pouvez également définir le nombre de fois où le résolveur DNS doit envoyer une demande de résolution (nouvelles tentatives DNS) en cas d'échec d'une recherche DNS.
Vous pouvez configurer NetScaler en tant que redirecteur DNS. Un redirecteur transmet les demandes DNS à des serveurs de noms externes. NetScaler vous permet d'ajouter des serveurs de noms externes et fournit une résolution de noms pour les domaines situés en dehors du réseau. NetScaler vous permet également de définir la priorité de recherche de noms sur DNS ou Windows Internet Name Service (WINS).