Managing RAID disk allocation on the SDX 22000 platform
View drive properties and operations
Logical drives
| State | Description |
|---|---|
| Optimal | The virtual drive operating condition is good. All configured drives are online. |
| Degraded | The virtual drive operating condition is not optimal. One of the configured drives has failed or is offline. |
| Failed | The virtual drive has failed. |
| Offline | The virtual drive is not available to the RAID controller. |
To create a new logical drive
-
Navigate to Configuration > System > RAID, and select the Logical Drives tab.
-
Click Add.
-
In the Create Logical Disk dialog box, select two slots that contain operational physical drives, and then click Create.
Physical drives
-
Slot:—Physical slot associated with the physical drive.
-
Size:—Size of the physical drive.
-
Firmware State:—State of the firmware. Possible Values:
-
Online, spun up:—Physical drive is up and is being controlled by RAID.
-
Unconfigured (good):—Physical drive is in good condition and can be added as a part of the logical drive pair.
-
Unconfigured (bad):—Physical drive is not in good condition and cannot be added as part of a logical drive.
-
-
Foreign State:— Indicates if the disk is empty.
-
Logical Drive:— Associated logical drive.
-
Initialize:—Initialize the disk. You can initialize the physical drive if it is not in good state and must be added as a part of the logical drive pair.
-
Rebuild:—Initiate a rebuild of the drive. When a drive in a drive group fails, you can rebuild the drive by re-creating the data that was stored on the drive before it failed. The RAID controller re-creates the data stored on the other drives in the drive group.
-
Locate:—Locate the drive on the appliance, indicated by causing the Drive Activity LED associated with the drive to blink.
-
Stop Locate:—Stop locating the drive on the appliance.
-
Prepare to Remove:—Deactivate the selected physical drive so that it can be removed.
Storage repository
-
Name:—Name of the storage repository drive.
-
Is Drive Attached:—Whether the storage repository is attached or not. If the drive is not attached, you can click Remove to delete.
-
Size:—Size of the storage repository.
-
Utilized:—Amount of storage-repository space in use.
Add a logical drive to the SDX 22000 appliance
-
Log on to the Management Service.
-
Navigate to Configuration > System > RAID.
-
On the back of the SDX 22000 appliance, insert the two blank SSDs in slot numbers 4 and 5. You can add the SSDs in a running system. Note: Make sure that the SSDs are NetScaler® certified.
-
In the Management Service, navigate to Configuration > System > RAID and the Physical Drives tab. You would see the SSDs that you added.
-
Navigate to the Logical Drive tab and click Add.
-
In the Create Logical Disk page:
-
In the First Slot drop-down list, select 4.
-
In the Second Slot drop-down list, select 5.
-
Click Create.Note: In Management Service, the slot number begins with zero. So the slot numbering in Management Service differs from the slot numbering on the physical appliance.
-
Add a second logical drive on the SDX 22000 appliance
Replace a defective SSD drive with a blank SSD drive
-
Navigate to Configuration > System > RAID.
-
On the Physical Drives tab, select the defective drive that you want to replace.
-
Click Prepare to Remove to remove the drive.
-
Click the refresh icon to refresh the list of physical drives.
-
Physically remove the defective drive from the slot.
-
Insert the new Citrix® verified SSD in the slot from where you removed the defective SSD.
-
In the Management Service, navigate to Configuration > System > RAID. The new SSD is listed in the Physical Drives section. The drive rebuild process starts automatically.